Emulation station does not recognize resolution from config.txt

Welcome Page Forums RetroPie Project Video Output on RetroPie Emulation station does not recognize resolution from config.txt

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of maestroni maestroni 1 year, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #106141
    Profile photo of maestroni
    maestroni
    Participant

    I have a samsung HDTV installed lengthwise in an arcade cabinet and I can’t seem to get emulation station output the 4:3 aspect ratio I set in the config.txt file. The emulators work properly when I start a game per the settings.

    The forum linked below is the closest thing I have found to a solution but it looks like the file structure of retropie has changed since this post and I am unable to get it to work with their instructions.

    https://github.com/Aloshi/EmulationStation/issues/55

    Here is my /boot/config.txt

    # uncomment if you get no picture on HDMI for a default “safe” mode
    #hdmi_safe=1
    display_rotate=3
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=0

    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=24
    #overscan_right=24
    overscan_top=50
    overscan_bottom=-50
    overscan_scale=1
    # uncomment to force a console size. By default it will be display’s size minus
    # overscan.
    framebuffer_width=640
    framebuffer_height=480

    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1

    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1

    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2

    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4

    # uncomment for composite PAL
    #sdtv_mode=2

    # for more options see http://elinux.org/RPi_config.txt
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256

    Attachments:
    #106143
    Profile photo of petrockblog
    petrockblog
    Keymaster

    ES won’t use the framebuffer width/height values. You could try switching to a 4:3 screenmode though.

    you can pass emulationstation a --resolution WIDTH HEIGHT parameter to change the render resolution which might help. you would need to edit /usr/bin/emulationstation to add the parameters or make your own launch script in /usr/local/bin

    however it may not position correctly on your screen, but it’s worth a try

    you may have performance issue using display_rotate btw – unfortunately es has no rotation setting of its own even though retroarch etc does.

    #106167
    Profile photo of maestroni
    maestroni
    Participant

    Thanks for the reply but I don’t understand how to do either of those.

    I went to /usr/bin/emulationstation and added a parameter after the line “fi”
    –resolution 640 480
    with no luck

    then I added the following code as mentioned in the forum linked below where the user seemed to have success.
    https://github.com/Aloshi/EmulationStation/issues/55

    pushd “$rootdir/supplementary/EmulationStation” > /dev/null
    ./emulationstation -w 640 -h 480
    popd > /dev/null

    still no luck

    Also, emulationstation does rotate and overscan per the config.txt file and seems to be running at normal speed, so at least I have that going for me.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar