Edimax EW-7811UTC Wifi adapter

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of Chosen Chosen 2 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #89596
    Profile photo of Chosen
    Chosen
    Participant

    Has anyone had any luck getting this adapter work with the RPi2? I’ve searched near and far from different linux sites abroad. Apparently someone was able to cross compile the drivers from unbuntu to work with raspbian on a RPi1; yet to no avail have I seen anyone able to come out with a working method for the RPi2 with the 3.18.7-v7+ Kernel?

    Would be awesome if someone out there knows of a method and could share.
    I’m running the 2.6 version of retropie for the RPi2 strictly with the command line only, no startx/guis.

    My last 2 big hurdles with my project are getting this wifi dongle to work and then getting SSH to work again. I have fought tooth and nail with this issue:
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that a host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    af:66:e1:3e:d9:b3:c0:07:89:b2:d4:27:f1:60:4c:8d.
    Please contact your system administrator.
    Add correct host key in /Users/jlogue/.ssh/known_hosts to get rid of this message.
    Offending RSA key in /Users/jlogue/.ssh/known_hosts:1
    RSA host key for 192.168.1.13 has changed and you have requested strict checking.
    Host key verification failed.

    [Process completed]

    I have searched HIGH and LOW for solutions but all of the ones I have found still do not allow me to connect from my mac. I’ve deleted the known_hosts file and created a new one. I’ve commented out certain things in ssh_config and sshd_config but still came across the error.

    Alas, my RPi2 plays Nes/Snes/n64/& psx games beautifully. I have it overclocked to 1ghz, gnu_mem is at 384, sdcard size is 64gb class 10, bluetooth working with ps3 controller. Everything works great except for my wifi and the ssh.

    #89604
    Profile photo of petrockblog
    petrockblog
    Keymaster

    remove line 1 of /home/user/.ssh/known_hosts

    #89611
    Profile photo of Chosen
    Chosen
    Participant

    the file is currently empty yet I still have the same error

    #89613
    Profile photo of petrockblog
    petrockblog
    Keymaster

    maybe the file is elsewhere that it is reading somehow ? Worth doing a locate/find on the filesystem and checking

    $HOME/.ssh/known_hosts
    /etc/ssh/ssh_known_hosts

    #89624
    Profile photo of Chosen
    Chosen
    Participant

    entered command: Home/.ssh/known_hosts
    received response: -bash: HOME/.ssh/known_hosts” No such file or directory

    entered command: /etc/ssh/ssh_known_hosts
    received response: -bash: /etc/ssh/ssh_known_hosts: No such file or directory

    the file is located in /etc/ssh, so I entered,

    entered commmand: /etc/ssh/known_hosts
    received response: -bash: /etc/ssh/known_hosts: Permission Denied

    I would assume this means that the only location where it is reading the information from is in that directory, which as I mentioned it is empty. Is there any way to disable “strict checking” I’ve searched and found examples to comment out specific lines in ssh_config and sshd_config, but still have the issues.

    “Offending RSA key in /Users/jlogue/.ssh/known_hosts:1
    RSA host key for 192.168.1.13 has changed and you have requested strict checking.
    Host key verification failed.

    [Process completed]”

    There is no /users/jlogue/.ssh/known_hosts on the RPi2, is this referring to a directory on my mac? Because when I do a search for known_hosts on my mac it returns nothing

    #89629
    Profile photo of Chosen
    Chosen
    Participant

    turns out that after opening a terminal on my mac i was able to:
    cd /
    ls
    cd users
    cd jlogue
    ls (i didn’t see .ssh or anything similar to it)
    cd /users/jlogue/.ssh/known_hosts
    (it returned permission denied to which this piqued my entered)
    sudo nano /users/jlogue/.ssh/known_hosts
    (it had the ip of my raspberry pi along with a key that I deleted)
    ctrl-x
    y

    and now i can finally ssh into my raspberry pi from my mac again. no more going back and forth between screens to read the command line.
    thank you for your assistance!

    Now if I could just get the wifi adapter to run I’d be all set!

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar