Dualshock 4 Controller via Bluetooth

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Dualshock 4 Controller via Bluetooth

This topic contains 15 replies, has 7 voices, and was last updated by  ewgeni 2 years, 9 months ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
  • #3885



    Is there any way to connect a Dualshock 4 (PS4) Controller to Retropie via Bluetooth?



    yep. I used ds4drv, but its to laggy

    now tryng bluez 5.21, but no luck



    in fact its easy

    this is instalation of bluez and other packegaes that we need
    sudo ./retropie_setup.sh
    Install sixaxis

    # YOUR_GAMEPAD_MAC can be obitain by using command hcmitool search

    echo 0000 | bluez-simple-agent hcmi0 YOUR_GAMEPAD_MAC
    bluez-test-device trusted YOUR_GAMEPAD_MAC yes

    and last

    sudo hidd –search

    you are AWESOME



    So if I see this correctly, there has not been anyone using a PS4 controller over bluetooth?
    I am using it via USB connection, it works fine. But of course, via BT would be even better. Is there anyone with experience in this field?

    Thanks a bunch in advance.


    Bryan Fieldingood

    expect a reply in a week from me… will have 7 days worth of a fool proof youtube video… hopefully. Will need as much support for motivation towards the new Steam OS Controller.


    Erick Peniche

    Any updates to this?? It will really help if someone update with their results.



    I’ll gladly get a Dualshock 4 (PS4) controller up and running, but I’ll need someone to donate a PS4 contoller to the cause. I don’t currently own a PS4 (though I’m saving for one), so I don’t have a controller right now. I’m working on an all inclusive instructions document for setting up RetroPie, contollers, and the like that is up to date with the current release, and hope to contribute more as I get more time.



    Any updates? DS4DRV is far too laggy to be used. Rei’s solution using Sixaxis Joystick Manager didn’t work for me, maybe I didn’t spend enough time at it. Has it worked for others?



    Same here, any news?




    i got my DS4 to work with these two Tutorials:



    If I remember correctly, I had to be fast with these 2 commands (I think both commands have to be executed while the light-bar is blinking)

    bluez-simple-agent hci0 75:EF:82:69:D2:83

    bluez-test-device trusted 75:EF:82:69:D2:83 yes

    Hopefully this will help you guys.



    I am getting authentication rejected when I attempt to pair it, did you get this error?



    Put a sudo in front of every bluez command and try again please.



    Still won’t work =( just sucks everything worked perfectly up until attempting to pair it. I wonder if it needs a PIN somehow? I noticed someone above was echo’ing 0000 but I’m not sure how that would even work. Did you install a driver or anything? I literally just imaged the SD card, updated all packages, installed bluez, scanned for device (found) and attempting to pair.



    Here are the exact commands I use to get my controller to work:
    1) Install Drivers
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install bluetooth bluez-utils blueman
    2) Check if Bluetooth is working
    /etc/init.d/bluetooth status (you should get: [ ok ] bluetooth is running.)
    3) Scan and Ping Device
    hcitool scan (Press the PS-Button and the share-Button at the same time to enter Pairing mode on the Controller)
    sudo l2ping -c 1 xx:xx:xx:xx:xx:xx %Replace xx with mac-address
    4) Connect Device (This works for me only if i paste these commands and execute them immediately one after the other)
    sudo bluez-simple-agent hci0 xx:xx:xx:xx:xx:xx
    sudo bluez-test-device trusted xx:xx:xx:xx:xx:xx yes

    5) Remove Device (if you need to delete a Device)
    sudo bluez-simple-agent hci0 xx:xx:xx:xx:xx:xx remove

    As I wrote for pairing i have to prepare the 2 commands separately and paste them in putty as fast as possible.

    I’m no expert but can you try to remove the device (Execute the command 2 or 3 times, you should get a long message which ends with Does Not Exist

    What message do you get if you ping the controller?
    You should get something like this: sudo l2ping -c 1 xx:xx:xx:xx:xx:xx
    Ping: xx:xx:xx:xx:xx:xx from xx:xx:xx:xx:xx:xx (data size 44) …
    52 bytes from xx:xx:xx:xx:xx:xx id 0 time 7.67ms
    1 sent, 1 received, 0% loss



    Yep I can scan it, I can ping it, it’s not an added device so it can’t be removed. I even pre-filled both lines and did them both super fast, still authentication rejected. =/ Just sucks since it works when connected via usb cable.



    Hi Everybody,

    yesterday i found this helpfull blog on how to connect my ps4 controller via bluetooth with my raspberry pi 2 model b.

    i followed the step by step guide from berni-h3 and everything worked fine until i reachead step 4 (Connect the device).

    i got the same error, that my controller can`t connect because of an authentication rejected. as smee wrote. so tried every singe variation with sudo without sudo and so on. but nothing was going to work for me.

    then i found this page Connect bluetooth keyboard to the pi

    the final soulution for me was, to go into the python script bluez-simple-agent and edit the argument ‘KeyboardDisplay’ to ‘DisplayYesNo’.

    hops this help you to

Viewing 16 posts - 1 through 16 (of 16 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss