Dual bluetooth 8bitdo NES30pro issue

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Dual bluetooth 8bitdo NES30pro issue

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of teirich teirich 1 year, 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #113297
    Profile photo of stahl80
    stahl80
    Participant

    Hi!

    just installed a bluetoothmodule and dual 8bitdo NES30pro controllers.
    Got the bluetooth part working quick thanks to all the available guides.
    Using one controller works perfect. But when connecting the other for two player games thing starting to act weird. The games works but trying to exit an emulator with my default hotkeys select+start suddenly stopped working. tried on both controllers, one time it worked but then nothing. rebooting and with just one bluetooth controller on everything os fine agin.

    Mostly i followed this guide, https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-Bluetooth-controller.

    In this step i added the second controller also:
    Edit this startup file
    sudo nano /etc/rc.local
    above the line “exit 0” add
    bluez-test-input connect XX:XX:XX:XX:XX:XX
    bluez-test-input connect “second-controller”

    Did i miss something or to i have to make additional editing for the hotkeys or something?

    grateful for any help!

    #114184
    Profile photo of teirich
    teirich
    Participant

    I believe the values you need to set in your controller.cfg file are:

    input_enable_hotkey_btn = “21”
    input_exit_emulator_btn = “22”

    The numerical values should be replaced with the value of your start/select keys

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar