DosBox Permission Denied

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of redhalo redhalo 2 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #93979
    Profile photo of wizard
    wizard
    Participant

    Ok, so I go to start the default and only .sh in my pc folder. In and out, no dosbox. My specs, steps and conditions are as follows:

    ================================================================
    pi@home$ cat /tmp/runcommand.log
    /opt/retropie/supplementary/runcommand/runcommand.sh: line 671: /home/pi/RetroPie/roms/pc/+Start DOSBox.sh: Permission denied

    This has something to either do with “retroarch_append_config” (close to what it said) or more likely “eval $command”
    ==================================================================

    -roms folder is symlinked to an external drive’s dir
    -most other emus work fine (haven’t checked them all)
    -chown was run on roms, /opt/retropie -R
    -chmod -R 777 /dev, /opt/retropie/emulators/dosbox/bin
    -retropie-setup and reinstall dosbox package
    -before the roms folder was symlinked, I copied everything over to the roms folder on the external drive, then deleted and symlinked

    -rpi2
    -512/512 mem split
    -tons of room on the hdd and the 16gb sdcard
    -fresh install
    -only kodi was installed after the fresh install
    ===================================================================

    Not sure what else is relevant, but I’m sure it’ll be easy enough to find. Anyone have any ideas why I don’t have permission to play with DOSBox?

    #93983
    Profile photo of herbfargus
    herbfargus
    Member

    You could try
    chmod -R 777 /home/pi/RetroPie/roms/pc

    #93987
    Profile photo of wizard
    wizard
    Participant

    Yeah, tried that after I posted.

    I did double check on running it outside of ES, and I have all capabilities as the user pi, i.e. mounting, running a game, etc. Does anyone know what is being called at line 671 that “pi” wouldn’t have permission to access?

    #94043
    Profile photo of redhalo
    redhalo
    Participant

    I know this one, just posted about it this past week trying to figure out the same thing. The hdd isn’t being mounted correctly to allow exec privilages no matter what you chmod. Edit /etc/usbmount/usbmount.conf and remove the noexec parameter, then reboot.

    https://github.com/retropie/RetroPie-Setup/issues/781

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar