Display games in their native aspect (disable full screen scaling)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Display games in their native aspect (disable full screen scaling)

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Floob Floob 2 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #81818
    Profile photo of seagoon
    seagoon
    Participant

    First of all thank you for Retropie – I’m only starting out with this software but already I am impressed with how easy it has been to get things setup. Currently I’m only testing out the PSX emulator on the 2.3 SD-card image. One issue I haven’t been able to figure out yet, despite trawling the forums and reading through the documentation is display scaling.

    Out of the box, RetroPie displays games stretched to fit the full screen. I’m not sure if this is a limitation of the RPi hardware or a configuration option I’m missing in RetroPie but the options I’ve tried toggling in the config files don’t seem to have an effect. My goal is to display the games in a 4:3 format taking up the full vertical height of the screen with black bars on each side of the horizontal.

    Has anyone had any luck with this? I am connecting to a 720p TV over HDMI if that is any help – please let me know if you require any config dumps, although I believe I am running things mostly stock.

    #81855
    Profile photo of Floob
    Floob
    Member

    Can you use the TV’s aspect ratio control?

    You can set the composite video output ratio here:
    http://elinux.org/RPiconfig#Video_mode_options

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar