Disable autostarting EmulationStation

Home Forums RetroPie Project Everything else related to the RetroPie Project Disable autostarting EmulationStation

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of jefflebowski jefflebowski 3 years, 12 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2120
    Profile photo of jefflebowski
    jefflebowski
    Participant

    Hello everyone,

    I’d like to add a boot menu to my Pi, such as this one: https://github.com/dweeber/bootmenu

    Currently I am running the RetroPie SD card image, where EmulationStation is set to automatically start up. I’d rather have a simple terminal, and later on put in the boot menu script as seen above, where I’ll press “1” for “startx”, “2” for “emulationstation” and just exit to command line when I don’t do a thing, for example.

    Until I have this script implemented, I’d like to simply stay in the command line on boot. How do I achieve this?

    #2121
    Profile photo of karloss
    karloss
    Participant

    run the retropie script, and selete setup, then disable emulationstation on boot option.

    #2122
    Profile photo of jefflebowski
    jefflebowski
    Participant

    Thanks, that worked fine. Could you also guide me in the right direction on how to implement that boot menu?

    #2137
    Profile photo of jefflebowski
    jefflebowski
    Participant

    The first reboot worked fine, but now a few hours later I tried to reboot, then I saw the “RetroPie Project” Splash Screen of EmulationStation followed by … nothing. All I see is a black screen. Pressing F4 or typing “startx” or anything else does exactly nothing.

    #2210
    Profile photo of petrockblog
    petrockblog
    Keymaster

    You should be able to change to the second terminal via Ctrl+Alt+F2 for debugging etc.
    You might want to report this issue at the Github repository.

    #2211
    Profile photo of jefflebowski
    jefflebowski
    Participant

    Starting the second console works and lets me enable ES at boot time so I can use the Pi again, thank you.

    But I have no idea how I can actually disable it. I have tried it another time with a clean install from the image, where I got the same problem: black screen after splash.

    #2272
    Profile photo of jefflebowski
    jefflebowski
    Participant

    Is there anybody who can help me on this issue? Every other problem I’ve got solved, the boot menu works, all is well. Just ES’s auto-boot sucks.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar