DGEN over Composite Video

This topic contains 8 replies, has 6 voices, and was last updated by  karloss 4 years, 5 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #1640

    Raygan Kelly

    Anybody have it working?

    I read this thread on the Raspberry Pi forum, but I couldn’t completely follow it. Some people seemed to say that they got it working but there were no explicit instructions.

    Currently, I get sound but no video.



    I would also like to know if anyone has this working.

    If I could get DGEN running over composite and be able to stretch osmose full screen for Sega Master System and be able to exit both emulators with my controller shorcut I created and am using for the other systems, my life would be complete.



    There is a thread about that with a possible solution at https://github.com/retropie/RetroPie-Setup/issues/161. This might also go into a next update of the RetroPie Setup Script.


    Raygan Kelly

    I tried what what was being discussed in that github issue thread, and it did in fact work for me. I am now able to get a picture over composite.

    I haven’t been able to get the image to scale to full screen, though. It doesn’t seem to be respecting my scaling settings in the dgenrc file, and is only filling about 3/4 of the screen. A definite improvement, but I’m still tinkering.



    Hi Raygan,

    Can you please give me an idea of what you did to get it to work? as I don’t quite understand exactly what I need to do from reading that thread.



    Raygan Kelly

    I downloaded and compiled the SDL dispmanx library as instructed:

    mkdir /home/pi/RetroPie/supplementary/dispmanx
    cd /home/pi/RetroPie/supplementary/dispmanx
    git clone –depth=0 git://github.com/vanfanel/SDL12-kms-dispmanx.git
    cd SDL12-kms-dispmanx
    nano Makefile

    // Now we need to edit the Makefile – there is a better way to do this I think but it works…
    // Append this to CFLAGS -I/opt/vc/include/interface/vmcs_host/linux
    // Save and exit

    // Run configure

    // Run make – DO NOT install – will break emulationstation and overwirtes some of your sdl library files

    Then I skipped the stuff about recompiling EmulationStation. I’m not sure why it was reccomended and when I tried it it broke EmulationStation, so I just reinstalled EmulationStation from sources and skipped on to changing the es_systems.cfg file to use the Dispmanx library instead of standard SDL when using DGEN.

    Edit your es-systems.cfg file to use this for DGEN:

    COMMAND=export LD_LIBRARY_PATH=”/home/pi/RetroPie/supplementary/dispmanx/SDL12-kms-dispmanx/build/.libs”; /home/pi/RetroPie/emulators/dgen-sdl/dgen %ROM%

    Worked for me anyway. I still can’t get it to fill the composite screen or exit from the controller but it’s totally playable.




    I´m new in this forum and I´m from Germany. I have the same problem with composite vieo, but with all emulators :(. But I can close dgen by pressing an controler button :).

    I edit the dgenrc file in /RetroPie/configs/all/

    # Quit DGen or switch to the next ROM on the command-line.
    key_quit = escape
    joy_quit = joystick0-button12

    Find this linke and put the name of the button you want, where it says joystick0-button12.

    I hope this work for you 🙂



    I am also hunting a solution to this. I really want to play NES emu over composite output. haha.

    I’ve tried the steps above, but the last step where I edit .emulationstation/es_systems.txt is probably wrong. I am confused by what is meant above.

    Here is the output of es_log.txt:

    lvl2: 	Attempting to launch game...
    lvl2: 		/home/pi/RetroPie/emulators/linapple-src_2a/Start.sh
    lvl2: 	Starting SDL...
    lvl2: 	Creating surface...
    lvl2: 	Resolution: 720x480...
    lvl2: 	Created surface successfully!
    lvl2: 	Loading theme "/home/pi/.emulationstation/nes/theme.xml"...
    lvl2: 	Theme loading complete.
    lvl2: 	Attempting to launch game...
    lvl2: 		/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 "retroarch -L /home/pi/RetroPie/emulatorcores/fceu-next/fceumm-code/fceumm_libretro.so --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/nes/retroarch.cfg /home/pi/RetroPie/roms/nes/Super\ Mario\ Bros.\ 3.nes"
    lvl2: 	Starting SDL...
    lvl2: 	Creating surface...
    lvl2: 	Resolution: 720x480...
    lvl2: 	Created surface successfully!

    The screen now just goes black. I’m not sure what I’ve done. haha



    Hey Raygan Kelly,

    I followed your steps, and didn’t seem to have any errors, but I still just get a black screen when trying to run my MD roms 🙁

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/