Genesis not returning to Emulation Station with Select+Start

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Genesis not returning to Emulation Station with Select+Start

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of heiNey heiNey 4 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1525
    Profile photo of jbaker1225
    jbaker1225
    Participant

    So I’m having a bit of an odd problem…

    I modified my Retroarch.cfg file to include:
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”

    Where 8 and 9 are the select and starts buttons on my USB SNES controller. In the NES, SNES, and GBA emulators, pressing start and select backs on out to Emulation Station.

    However, on Genesis nothing happens. I’ve also noticed that in Genesis games, the select button is actually functioning as start.
    Maybe those are correlated? I also can’t seem to find any Genesis or Megadrive .cfg file to look into when I’m exploring in LXDE. But I’m very new to this, so I might be missing something.
    If anybody has any suggestions or knows why this is happening, advice is appreciated. Thanks.

    #1531
    Profile photo of Mutex
    Mutex
    Participant

    The Genesis emulator used in retropie right now is not part of retroarch. So changing stuff in the retroarch.cfg won’t change anything in that specific emulator. In your config/all/ folder lies a second config file next to your retroarch.cfg. It’s called dgen.* (don’t remeber the exact name). That’s the file you’re looking for. When you open the file you will see that it already has configured bindings for your gamepad. To change your select & start button on  the gamepad just switch the values of the two entries:

    joy_pad1_mode = joystick0-button9
    “joy_pad1_start  = joystick0-button8

    I don’t now if it is even possible within DGEN (the Genesis emulator) to emulate the behavior of the hotkey button thingy in retroarch, but you can add a custom exit button to that config.

    Hope I could help you & good luck changing the config.

    #1532
    Profile photo of jbaker1225
    jbaker1225
    Participant

    Thanks. That certainly helps explain why the behavior is not the same.

    Would you happen to have any idea how to add a custom exit button to the config? Say I wanted “Select” to just be the exit button in Genesis?

    And since you’re not sure if there’s a way to replicate the “hotkey” aspect, do you know if there’s any way to create some other sort of button combination? For instance, I could have whatever command functions as exit “=joystick0-button9 + joystick0-button8”?

    Sorry for inundating you with questions. Like I said, I’m just totally new and trying to get the hang of this stuff.

    #1563
    Profile photo of heiNey
    heiNey
    Participant

    Thanks. That certainly helps explain why the behavior is not the same. Would you happen to have any idea how to add a custom exit button to the config? Say I wanted “Select” to just be the exit button in Genesis? And since you’re not sure if there’s a way to replicate the “hotkey” aspect, do you know if there’s any way to create some other sort of button combination? For instance, I could have whatever command functions as exit “=joystick0-button9 + joystick0-button8″? Sorry for inundating you with questions. Like I said, I’m just totally new and trying to get the hang of this stuff.

    i mapped joystick0-button6 (which is the L2 button) to joy_quit and it exits the game back to emulationstation.  i cant figure out how to make it a 2 button press so that you dont accidentally exit the game by pressing that button though.

    #1564
    Profile photo of heiNey
    heiNey
    Participant

    how weird.  everything was working, rebooted the rpi and now my d-pad doesnt work, but my left analog stick started to work…except the up button is “stuck”.  i’d rather have the d-pad though.  hmm

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar