dgen not detecting save file or special key function

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project dgen not detecting save file or special key function

Tagged: , , ,

This topic contains 1 reply, has 1 voice, and was last updated by  jplaj 4 years, 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2655

    jplaj
    Participant

    Hey, I’ve had some trouble with dgen lately. I’m trying to play through “Shining Force,” but when I reload after shutting down, dgen doesn’t seem to recognize my save file. It’s there…under ~/.dgen/ram there’s a “Shining Force” file, but when I load the game it doesn’t seem to know it’s there.

    I dug around dgenrc for a while to see if I could find something like retroarch’s autosave_interval feature, but couldn’t find anything.

    Then I tried setting my spare keys to do savestates….

    joy_save = 'joystick0-button0'
    joy_load = 'joystick0-button4'

    But dgen doesn’t seem to recognize them, either. It does, however, recognize my exit emulator feature, which I’ve had set up for some time in the exact same way (except with joystick0-button5)

    Any ideas how I can save my game? I’d prefer in-game saves over save states, but would like to know how to get both working, if possible. Thanks.

    #2656

    jplaj
    Participant

    Update: I figured out the save state problem (my hub actually forces me to use controller 3 as player one), but still not sure about how to read the in-game save file.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss