Delayed audio in Mupen64 with Mario 64

Home Forums RetroPie Project New to RetroPie? Start Here! Delayed audio in Mupen64 with Mario 64

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of scoularis scoularis 1 year, 6 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #111481
    Profile photo of scoularis
    scoularis
    Participant

    So I’ve been trying everything I can to get Mario 64 running properly on my overclocked Pi2, and I’m so very close. The game runs too poorly on the Libretro version of Mupen64 no matter what video renderer I use, so I scratched that option.

    Everyone says that the standalone Mupen64 works better, so I tried that with gles, rice, and Glide64 plugins. Rice has lighting issues on Mario and the environment, and Glide64 slows to an unplayable crawl. Gles, on the other hand, runs beautifully… with one aggravating exception: all sounds are delayed about a full second behind every action.

    I’ve tried setting the audio latency in the mupen64plus.cfg down to 100ms (from the 300ms default), but it made no difference. I see no mention of this problem anywhere else, so I’m at a loss. Any help would be greatly appreciated.

    All other emulators/cores (NES/Gameboy/SNES/Genesis… etc.) run perfectly with no sound delay.

    #111494
    Profile photo of dankcushions
    dankcushions
    Participant

    i have the same issue, so giving you a bump! seems to happen in mario kart 64 also.

    i’ve not tried it, but you might want to try turning off video_threaded in retroarch.cfg – i think it’s bad news for performance but it might ensure the sound stays in sync??

    #111506
    Profile photo of scoularis
    scoularis
    Participant

    i have the same issue, so giving you a bump! seems to happen in mario kart 64 also.

    i’ve not tried it, but you might want to try turning off video_threaded in retroarch.cfg – i think it’s bad news for performance but it might ensure the sound stays in sync??

    Thanks for the reply. Now at least I don’t feel like I’m going crazy. I haven’t seen any mention of this anywhere else, and all videos of Mario 64 running on Mupen64 on the Pi2 on YouTube don’t seem to have the delay. Then again, some of them are using the rice plugin, which is immediately evident when you see the screwed up lighting on Mario’s face.

    Not sure about turning off threaded video. I’ve tried turning on Hard GPU Sync, but it didn’t alleviate the sound delay.

    #111551
    Profile photo of dankcushions
    dankcushions
    Participant

    sorry – i’m probably off on threaded video – that’s a retroarch setting and this isn’t a retroarch emulator! however there does seem to be some sort of audio issue with mupen64plus – https://github.com/RetroPie/RetroPie-Setup/issues/1124

    #111620
    Profile photo of dankcushions
    dankcushions
    Participant

    apparently this is now fixed (thanks to jools and stefan)! update retropie-setup, install individual emulators, and grab the latest mupen64plus binaries.

    #111621
    Profile photo of scoularis
    scoularis
    Participant

    Yep, it is. I tried it out this morning, and the audio lag is gone with the latest binary.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar