darkplaces(quake) in Emulstation

This topic contains 1 reply, has 2 voices, and was last updated by  bitpixel 3 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #12825


    Hi just somehow managed to add a link inside the ports section to open quake. This tutorial helped a lot installing darkplaces.
    To install darkplaces, quake an connect it to Emulstation i did the following:
    First Update your pi and reboot

    sudo rpi-update
    sudo reboot

    Create a darkplace folder in retropie emulator section could be you need sudo
    $ mkdir /opt/retropie/emulators/darkplaces
    Get darkplaces install data from here. unzip the dprpi_v1.1.zip file into the darkplaces folder then install darkplaces by running the deb file.
    sudo dpkg -i darkplaces-rpi.deb
    Now Get quake106.zip and unzip into darkplaces Folder afterwards you need to install lhasa and load the quake ressources by

    sudo apt-get install lhasa
    sudo lhasa e resource.1

    Now you should be able to run quake via commandline to connect it to ports change to roms/ports folder and add a new file quake.sh with this content:

    sudo darkplaces-sdl -quake -basedir /opt/retropie/emulators/darkplaces/

    Now you just need to make the sh file executable
    sudo chmod +x /home/pi/RetroPie/roms/ports/quake.sh
    and it should work.



    Please help got an issue with this

    I followed this guide and it installed well.
    Demo is working sound is working
    but if i open a game the player starts spinning to the left

    *controls are working i can temporarily counteract this movement with the mouse
    *i tried reinstalling with the guide of autonomous = no luck
    *checked the permissions they are ok
    *tried sudo dark places-sdl = no luck
    *tried no anti aliasing as suggested in another forum = no luck
    * keyboard mouse and joystick responding well in other emulators/ports

    my setup
    -retropie 2.3
    -fully updated ; upgraded ; firmware updated
    -wireless keyboard/mouse
    -wireless joystick logitech f710
    i suspect an issue with the f710 because if i reboot without the dongle the problem is resolved but of course i would like to have the dongle stay connected

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/