D-Pad does not work in game

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! D-Pad does not work in game

Tagged: , ,

This topic contains 2 replies, has 2 voices, and was last updated by  woundjuice 3 years ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #108733

    woundjuice
    Participant

    I have done a fresh image install of retropie 3.2 and configured my gamepad on initial boot onto EmulationStation. The gamepad works perfectly in EmulationStation, but as soon as I load an NES ROM the D-Pad does not work in game, but other buttons work as expected. I have tried removing the config file through SSH and rebuilding using the retropie_setup.sh script. No change.

    I have tried multiple ROMs in multiple emulators, all have the same problem.

    Config File:

    input_device = “USB Gamepad ”
    input_driver = “udev”
    input_b_btn = “0”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    input_reset_btn = “0”
    input_state_slot_increase_axis = “+0”
    input_state_slot_decrease_axis = “-0”

    Pi Model: 2
    RetroPie Version Used: 3.2
    Built From: SD Image
    USB Devices connected: 1
    Controller used: USB NES Controller
    File: /opt/retropie/configs/all/retroarch-joypads/USBGamepad.cfg

    #108735

    gizmo98
    Participant

    Open /opt/retropie/configs/all/retroarch.cfg and remove
    input_player1_analog_dpad_mode = 1
    input_player2_analog_dpad_mode = 1
    input_player3_analog_dpad_mode = 1
    input_player4_analog_dpad_mode = 1
    input_player5_analog_dpad_mode = 1
    input_player6_analog_dpad_mode = 1
    input_player7_analog_dpad_mode = 1
    input_player8_analog_dpad_mode = 1

    #108736

    woundjuice
    Participant

    yeah i was just going to update this hahaha…. Thanks for the quick reply though! Tested and this is confirmed the problem. I just commented out the lines.

    found it here:

    [Solved][RP 3.2] 2 Axis, 8 button controller d-pad problems (iBuffalo)

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

We use Cookies and similar technology to collect and analyse information about the users of this website. We use this information to enhance the content, advertising and other services available on the site. Please click ‘Accept cookies’ to consent to the use of this technology by petrockblock. You can manage your preferences at any time by visiting our Cookies Policy page.