Crackling sound with snes9x-next and RPi 2

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Crackling sound with snes9x-next and RPi 2

This topic contains 4 replies, has 2 voices, and was last updated by  ertain 2 years, 7 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #96267


    Hello everyone.

    I installed RetroPie (binary packages via the RetroPie script) on my Raspberry Pi 2 last night and it looks pretty snazzy. I started it up, messed around with it, and liked what I saw. But when I started playing games, I hit a wall.

    When I play a big game like Seiken Densetsu 3, the sound is terrible (crackling and can’t keep up with the game). The emulator I’m using is snes9x-next. The reason for that is because that’s the only emulator which can actually display the ROM correctly (textures, text, and all).

    I have overclocked the device to the “High” settings, yet that hasn’t solved the problem. I have also changed the “audio_driver” setting in the retroarch configuration file (retroarch.cfg) to “sdl2” as well as “alsathread,” but those haven’t helped, either. Also, other emulators haven’t run properly.

    I have tried PocketSNES, but the resolution doesn’t look so good. PiSNES can’t even render the resolution properly. And other available emulators don’t even hold a candle to PiSNES nor snes9x-next.

    Here’s my set-up, if that helps:

    • Raspberry Pi 2 B
    • HDMI connection
    • HDTV which can display 1080P @ 60Hz
    • Raspbian with recently-installed RetroPie
    • Using Wii U Pro Controller via a Bluetooth dongle

    And here’s a couple of my configuration files:
    retroarch.cfg file
    Raspberry Pi 2 boot settings (note: this config file was changed to the “None” settings for the Raspberry Pi.)




    I am in no way an expert however I can share with you my findings that I used to get smooth sound in PSX Emulation.

    When I was in the PSX emulator I pressed the hotkey and F1 to bring up the menu.

    I then went to Options, than Core Options. You will see an option called “Dynamic Recompiler”, ensure that this is enabled.

    There is another option called “Enhanced Resolution”, ensure this is disabled.

    Sound on PSX works flawlessly doing this, I hope this helps you.



    Thanks for the reply, jamesandjomes-com. But what exactly is the “hotkey” you speak of? Or rather, what’s the default hotkey? Control? Alt?




    I think it is Ctrl + F1.

    My hotkey is select on my controller. Enter a game and then press these to access the menu. Good luck.



    Nope, that “dynamic recompiler” wasn’t found in the list of options. Heck, I even tried tweaking the audio delta setting as well as that block setting and those didn’t work.

    Edit: I have tried using the core lr-catsfc before. While the sound works under that core I get vertical lines going down some of the sprites (I had attached a screenshot showing the problem).

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at