Crackling sound in PSX games, RPI2

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Crackling sound in PSX games, RPI2

This topic contains 6 replies, has 4 voices, and was last updated by Profile photo of neighbourhoodnerd neighbourhoodnerd 2 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #88084
    Profile photo of dddaaannnhhh
    dddaaannnhhh
    Participant

    Has anyone gotten fluent psx audio emulation on their RPI2? I’ve tried messing around with the sample rate and latency to no avail. Video emulation is at ok speeds for me, but the crackling audio kinda ruins the experience. I frequently get ALAS buffer underrun occurred reported. Same with GBA. The other emulators, FBA, Snes, Nes and Genesis, works perfect. I’m using the 2.5.0 image with updated binaries and scripts. Any help would be appreciated!
    Oh, and I’m using the RPI2 over clock mode.

    On a side note, Retropie is the most awesome thing ever. To grab a cup of coffee and blast through Castlevania on NES before going to class is a terrific way to start the day.

    #88116
    Profile photo of Roo
    Roo
    Participant

    No crackling here. Some games I’ve tried are Crash Banicoot, GT, NFS and Silent Hill.

    You’re not using shaders are you? How are you getting video and audio out of the Pi? What is your memory split at?

    #88164
    Profile photo of dddaaannnhhh
    dddaaannnhhh
    Participant

    Save for dabbling with the audio settings, everything is stock 2.5 beta image with updated scripts / binaries through setup. This is mainly due to me being very new to both linux and RPI. My current config.txt in /boot says gpu_mem_1024=384, does that mean it is split at 384mb for gpu?

    I’m using HDMI out and the display reports 720p output.

    I’m glad you can run psx games well! Gave me some hope. Silent Hill is one game in particular I look forward to playing through again.

    Edit: I do not have sound issues in GBA. Not sure where I got that from, tested a lot of games now and not a single one has crackling sound. It’s just PSX. The two games I’ve tried are Einhander and Castlevania Chronicles

    #88179
    Profile photo of Roo
    Roo
    Participant

    I’m not sure that actually sets the memory split, I think it may just be a recommended value. Try sudo raspi-config and under advanced you can set memory split to 384. Once you do that you’ll see the new entry in /boot/config.txt

    I’ll try those games you mentioned tonight and let you know if I see any issues

    #88180
    Profile photo of petrockblog
    petrockblog
    Keymaster

    gpu_mem_1024 sets the memory split for a pi2

    gpu_mem_512 sets it for a B/B+ with 512mb ram

    gpu_mem_256 sets it for a 256mb model

    we use these instead of gpu_mem= so the default is reasonable for all machines.

    #88185
    Profile photo of Roo
    Roo
    Participant

    @buzz when I launch raspi-config and select memory split, it shows the setting currently at 64. Is this just because raspi-config isn’t smart enough to recognize the variable memory settings you are using in /boot/config.txt?

    #88418
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    Heh, same problem here. Never thought I’d complain about this for the Pi, but my PSX emulation seems to be too fast! The video plays too fast for the audio to keep up!

    Now, this may be because I’m using my old Retroarch.cfg. Here is what it currently has in it, aside from joypad stuff:

    system_directory = /home/pi/RetroPie/roms/../BIOS
    config_save_on_exit = false
    rewind_enable = false
    rewind_buffer_size = 10
    rewind_granularity = 2
    input_rewind = r
    input_shader_next = m
    input_shader_prev = n
    input_autodetect_enable = true
    joypad_autoconfig_dir = /opt/retropie/emulators/RetroArch/configs/
    video_aspect_ratio = 1.33
    video_gpu_screenshot = true
    video_shader_dir = /opt/retropie/emulators/RetroArch/shader/
    video_fullscreen_x = 640
    video_fullscreen_y = 512
    video_vsync = false
    video_threaded = true
    video_smooth = false

    Any suggestions?

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar