Could someone their retroarch.cfg?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Could someone their retroarch.cfg?

This topic contains 5 replies, has 2 voices, and was last updated by  alexbridgez 4 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #3047


    After using various controllers and manually editing the retroarcg.cfg file on /all, i’ve managed to have duplicates of almost every control mapping, which results in buttons doing the wrong thing or nothing at all. It would be great if someone could upload their own retroarch.cfg so I could edit it and get my controller working without having to reinstall and add ROMs again. I’m running the latest RetroPie SD card image if that makes any difference to the cfg file. Thanks! 🙂



    Before you lose your sanity in frustration (as I almost did).

    Have you tried setting up your controls using the Retroarch Joyconfig tool?

    cd RetroPie/emulators/RetroArch/tools *Press Enter*
    ./retroarch-joyconfig >> ~/RetroPie/configs/all/retroarch.cfg *Press Enter*

    Follow the prompts to set up your game controller. The output will be placed in

    Even if it doesn’t end up working properly (I found it didn’t pick up my analog
    sticks correctly). It gives you a good idea as to the actual button numbering
    vs the numbering on the controller.

    If you have 2 identical controllers, you can copy and paste the control settings
    of Player 1 just below and change the Player number from 1 to 2 and the control
    index from 0 to 1.

    Let me know if you’d still like me to upload my retroarch.cfg file. It looks
    strange when viewed in notepad from a Windows PC, so is best viewed on the Pi



    I’ve tried multiple times with retroarch-joyconfig and it hasnt solved my problem
    🙁 Please could you upload your retroarch.cfg? That would be awsome cheers 🙂



    I’ve attached my Retoarch config file from my configs/all directory. I’m using generic PS2 style controllers by Dragonrise inc.

    Hope it helps.



    Thanks! I’ll update if it works 🙂



    Well it’s better than it was before but the buttons do different things in each emulator and the enable_hotkey button (select) seems to be on whatever happens :/ off to bed now but will try again tommorow…mite give ES Config a try…

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss