Controllers working fine on ES but not on emulators

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Controllers working fine on ES but not on emulators

This topic contains 7 replies, has 5 voices, and was last updated by Profile photo of kemo87 kemo87 1 year, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #108028
    Profile photo of gerd

    Hi! This is the last step I need to make my retropie system (Rpi 2 with retropie 3.1 in SD image) work properly. I’m currently trying to use a twin USB controller (that means two ps1 dualshocks connected into a single USB adapter). At emulation station everything works fine and I can configure the pads. However, every emulator I run displays the message “twin USB joystick not configured” at the bottom of the screen in yellow while booting, and then the games don’t respond to them. How can I solve this?

    Profile photo of dankcushions

    this thread might help?

    Dual PSX Adaptor – only one working

    Profile photo of gerd

    Well, not exactly. They appear to function in emulationstation, while navigating between menus and selecting the console and game. However, after entering the game they become iresponsive with the message “twin USB joystick not configured” appearing while booting. I have tested it and the same thing happens with a wired PS3 controller.

    As stated here

    I was hoping that “Your joypad is automagically configured for libretro (retroarch) emulators when you configure your controller for the first time in emulationstation.”. However, it doesn’t appear to be the case. Maybe I should configure it manually, but I’m not sure how. There is a lot of information about older versions of retropie with the menus, but the names and order have changed slightly.

    Profile photo of dankcushions

    so a wired ps3 controller gets the same error, even without using the dual USB thing?

    hmm, in that case I think you might need to configure it manually. i’m not sure why the scripts haven’t worked for you. i’ve had to do that myself recently for an arcade stick – I think you need to follow these instructions:

    Profile photo of gerd

    Update: following dankcushions suggestion, I verified that there was no joypad config file (I don’t know why, in version 3.1 of retropie this was supposed to be created automatically, but apparently it doesn’t always happen). So I entered manually to the Retroarch setup configuration -> Input devices -> Joystick and pressed the buttons in the asked order.

    After that, all the emulators worked fine, except for the fact that the dualshock analog controls didn’t work (remember I’m using a twin Usb joystick, with two ps1/ps2 dualshocks plugged in). I could solve it by editing the file retroarch.cfg in /opt/retropie/configs/all/retroarch.cfg

    Two parts needed modification. First, set:

    input_libretro_device_p1 = “5”
    where p1 above is the player number, like p1, p2, etc

    Also, the D-Pad section needed to be modified (for 2 players) in the following way:

    # Axis for RetroArch D-Pad.
    # Needs to be either ‘+’ or ‘-‘ in the first character signaling either positive or negative direction of the axis, then the axis number.
    input_player1_up_axis = -1
    input_player1_down_axis = +1
    input_player1_left_axis = -0
    input_player1_right_axis = +0
    input_player2_up_axis = -1
    input_player2_down_axis = +1
    input_player2_left_axis = -0
    input_player2_right_axis = +0

    Profile photo of raspfan

    H everyone,

    I had recently quite the same problem.

    After my first install of Retropie few weeks ago on my Rasp 2, I configured the controller (a generic USB pS3 like) and everything went fine with most emulators.

    Today, I observed that the controller is working in ES but not anymore with the emulators. I’ve tried many options and I really don’t understand, always this message on the bottom page of a started game : “usb gamepad (5227/21760) not configured”…

    Thanks for your help !

    Profile photo of herbfargus

    Try reconfiguring it again as it doesn’t look like it configured for retroarch

    Profile photo of kemo87

    Same problem here. I have Logitech F510 gamepad. If i boot Pi and play a game, controller working. But if I leave a game and wanna play another game controller not working in game, working only on emulation station. If I restart Pi, controller start working, but only on first game again.

    Rpi2 B

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar