Controller works in menu, but not in emulators

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Controller works in menu, but not in emulators

This topic contains 19 replies, has 3 voices, and was last updated by Profile photo of toddforester toddforester 3 years, 2 months ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #5817
    Profile photo of shakyluigi
    shakyluigi
    Participant

    Hi.

    Sorry for making another post about controller not working, but I’ve been googling and searching for so long, I’m at my wits end.

    I have installed RetroPie using these instructions:

    http://lifehacker.com/how-to-turn-your-raspberry-pi-into-a-retro-game-console-498561192

    The controller works in the menu, but when I enter a game in either the nes or snes emulators (the only systems I have roms for), the controller is unresponsive. I have tried several different solutions, but I’m mostly stumped as I don’t seem to be able to type in the different commands needed, for example this one:

    http://raspberrypi.stackexchange.com/questions/1189/joystick-gamepad-not-working-in-retroarch

    I have also tried this, where it registers my input both in the “setup” and “test”:

    Update for the RetroPie Setup Script: Support for RetroArch’s Autoconfig Functionality and (wired) Xbox 360 controller support

    If I try to repeat the process, it seems to forget the earlier input. Or is it possible that it doesn’t save at all?

    I am using a snes usb controller I bought of Ebay.
    Is there a way to help me, or am I just technically inaduqate?

    #5819
    Profile photo of toddforester
    toddforester
    Participant

    hi, i had a good laugh when i read “technically inadequate” so thanks for that.

    ok so what happens when you do
    ls /dev/input/
    in the console?

    it should show js0 and/or js1 amongst other things.
    also could you attach your config file located at
    /home/pi/RetroPie/configs/all/retroarch.cfg
    in your reply so we could have a look at it.

    for my (original) nes controller i have this in my retroarch.cfg

    # If desired, it is possible to override which joypads are being used for player 1 through 8.
    # First joypad available is 0.
    input_player1_joypad_index = 1
    input_player2_joypad_index = 0
    
    input_player1_a_btn = 3
    input_player1_b_btn = 1
    input_player1_start_btn = 7
    input_player1_select_btn = 6
    input_player1_left_axis = -0
    input_player1_right_axis = +0
    input_player1_up_axis = -1
    input_player1_down_axis = +1
    
    input_player2_a_btn = 3
    input_player2_b_btn = 1
    input_player2_start_btn = 7
    input_player2_select_btn = 6
    input_player2_left_axis = -0
    input_player2_right_axis = +0
    input_player2_up_axis = -1
    input_player2_down_axis = +1

    the part about input_player1_joypad_index = 1 is like that purposely because i wired or read a diagram backwards but if that is the only controller plugged then yours should be
    input_player1_joypad_index = 0

    i have faith that the awesome members of this forum will be able to help you solve the problem with the right bit of information.

    i have attached my retroarch.cfg so you can look at it.
    go down to the input section (while looking at the file press ‘ctrl + f’ and in the search type “#### Input”)

    Attachments:
    1. retroarch.txt
    #5841
    Profile photo of shakyluigi
    shakyluigi
    Participant

    Hi.

    I’m glad I made you laugh. Makes me happy 🙂

    And thanks for a quick response.

    I’ve looked at your .txt file and I’ve tried to copy a few lines (modified to suit my setup). I noticed that my section:

    # input_player1_a_btn = 3
    # input_player1_b_btn = 1
    # input_player1_start_btn = 7
    # input_player1_select_btn = 6

    Had squares in front of them, while yours didn’t. There were also several other differences in the input section, but you’ll probably find them as I did.

    The changes didn’t work, and even at one point I made my RetroPie unable to enter games. Of course I made some backups of the orignial retroarch.cfg file, which is uploaded here as requested.

    I entered
    ls dev/input/
    and it showed js0, among other things, so it seems it can find the joypad.

    #5845
    Profile photo of toddforester
    toddforester
    Participant

    I’m not able to see your config file. I had to rename mine from .cfg to .txt in order for it to upload properly.

    #5846
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Anything with a number symbol ‘#’ in retroarch.cfg is commented out, remove the # to enable

    If you have found the solution to your problem please mark the topic as resolved.

    #5853
    Profile photo of shakyluigi
    shakyluigi
    Participant

    trimmtrabb: Thanks, I’ll give it a try.

    toddforestern: I’m trying to upload it as a txt file now.

    Attachments:
    1. retroarch1.txt
    #5855
    Profile photo of toddforester
    toddforester
    Participant

    which emulators have you tested with?

    #5856
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    how are you editing your retroarch.cfg, via nano or FTP’ing over?

    If you have found the solution to your problem please mark the topic as resolved.

    #5859
    Profile photo of shakyluigi
    shakyluigi
    Participant

    I have tried NES and SNES.

    I am using CybderDuck. So I guess FTP’ing?

    #5860
    Profile photo of toddforester
    toddforester
    Participant

    I was reading elsewhere on the forum that someone was using cyberduck and having problems try editing directly from the pi with

    sudo nano /RetroPie/configs/all/retroarch.cfg

    then make the changes and press Ctrl + x then y then enter to save and exit.

    #5862
    Profile photo of shakyluigi
    shakyluigi
    Participant

    I wrote in that command, and it brought med to a new screen, which had many commands in the bottom, but the entire screen was black.

    I’m guessing I should have seen the retroarch.cfg file and be able to edit it there?

    #5863
    Profile photo of toddforester
    toddforester
    Participant

    unless I wrote the path incorrectly you should have seen the config files contents. (I’m at work so I can’t check that the path I wrote is correct). another thing to try is to startx and open the file browser and go to where the configs are kept and right click the retro arch.cfg and click to open with leaf pad. edit it and save it from there.

    #5864
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    LXDE gui isn’t installed on the latest RetroPie image if that’s what you’re using. The location of retroarch.cfg is /home/pi/RetroPie/configs/all/retroarch.cfg

    If you have found the solution to your problem please mark the topic as resolved.

    #5865
    Profile photo of toddforester
    toddforester
    Participant

    oh, so I forgot /home/pi/ my mistake. and that’s weird because I’m sure I grabbed the latest image and I was able to start the x GUI ??? I could be wrong I may have grabbed an outdated version. I updated through the retropie-setup script

    #5866
    Profile photo of shakyluigi
    shakyluigi
    Participant

    Thank you both! That worked. There is a small “but” here. Almost all the buttons are ok. I can’t get the start and select button to work. I suspect this is just a matter of typing in the correct number. Is there a fast way I can figure out which number corresponds with which button? If not, then I’ll just do a bit of testing and see if I can figure out which one is which.

    #5867
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Glad you’re getting somewhere 🙂

    You can use jtest to determine buttons, run:

    sudo apt-get install joystick

    then

    jstest /dev/input/js0

    If you have found the solution to your problem please mark the topic as resolved.

    #5868
    Profile photo of toddforester
    toddforester
    Participant

    try
    jstest /dev/input/js0
    for controller 1 and
    jstest /dev/input/js1
    for controller 2
    i believe it tells you the button numbers there and you can see when you press one it’ll change from off to on.

    #5869
    Profile photo of toddforester
    toddforester
    Participant

    haha he beat me to it .
    have fun playing.

    #5870
    Profile photo of shakyluigi
    shakyluigi
    Participant

    Great! This worked like a charm. I had been trying for about two days to get this to work, and BAM, you guys fix it in 1 work hour (not counting down time ;)).

    Thanks again. I can’t really give you something over the Internet, but here’s a funny video from my country:

    Enjoy 🙂 And thanks again.

    #5871
    Profile photo of toddforester
    toddforester
    Participant

    no problem thats why we are here… well if we arent trying to solve our own broblems and what not. im really glad to have helped.
    i hope you stick around the forum so maybe you could help people as we helped you. take a look at my project that i posted here :

    http://blog.petrockblock.com/forums/topic/prepare-yourselves-i-think-its-original-nesberrypi-portable/

    let me know what you think so far.

Viewing 20 posts - 1 through 20 (of 20 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar