Controller trouble, transfer trouble….

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Controller trouble, transfer trouble….


This topic contains 3 replies, has 2 voices, and was last updated by  retroj 3 years ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #83768


    Good morning,

    Brand new here and still working out the kinks with my firsr rEtro console rpi.

    I’ve got my iBuffalo controller to work with the emu station but not in any of the games. I read another post which had the following

    Autoconfig file

    RetroArch config file

    Whenever I type the stuff above it says directory not found, not sure if I’m doing something wrong or not putting the correct command before the first / but I can’t seem to access the controller config files. Again, I’m brand new to this whole deal, but I’m relatively Tech savvy. Not used to this OS is all.

    Also, does the USB only xfer a certain amount of rom files at a time? I got about 50% to transfer and all the files are the correct extension etc. although I did have to run fsck so not sure if I should format the USB and load the missing roms.

    Lastly, all the mames just flicker a black screen and exit to emu station.

    Any help is appreciated.



    UPDATE: alright so I’ve figured almost everything out. I can manually config the controller modifying the master config file (/all) or individually. I got the resolution issue resolved as well.

    My only problem is when I configure the controller either manually modifying the config.txt or having it ask me the inputs, the mapping is completely messed up. Start/select move, left arrow jumps and shoots, etc. as if buttons are double mapped and not mapped correctly.

    I looked at someone’s configuration file for iBuffalo and copied it exactly which helped but a lot of stuff is still off or double mapping.

    I also plugged in a Logitech dual stick controller and experienced essentially the same issues

    Buttons aren’t mapping correctly. Please help!



    I wanted to update this as resolved after reading some other posts (apparently controllers are a big issue!) and share how I fixed it.

    I manually accessed my /all/ retroarch.cfg file and scrolled all the way down until I found my inputs. For one reason or another, when I autoconfig’d my BuffaloPad it pasted a new set of controller inputs on the end of the original one everytime I used auto config so there was like 20-30 repeated versions of however I put my inputs in. So I had to delete like 200 lines of controller inputs and manually set mine to the correct inputs and added exit/savestate shortcuts.

    Everything worked! No more multi-mapped buttons!



    Can you please describe how to do configure these controllers step by step? Including the exit/save shortcuts.

    I’ve been trying to configure for days now. I’m only finding outdated information..

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss