Controller setup working fine on menu, but not in game

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Controller setup working fine on menu, but not in game

This topic contains 29 replies, has 6 voices, and was last updated by Profile photo of pi-guy pi-guy 1 year, 9 months ago.

Viewing 30 posts - 1 through 30 (of 30 total)
  • Author
    Posts
  • #101202
    Profile photo of davidgourde
    davidgourde
    Participant

    Hi all, I’m new to all of this and I installed the image with version 3 beta 4 on my Pi 2.

    I am using a PS2 controller with a USB adapter. The controller works perfectly with the emulation station menu, but in game it’s not set correctly.

    In Snes, Select and Start works, and a button (a or b) but that’s it.

    I tested removing the .cfg in the config/snes folder and made a new config file, saved and rebooted, but it’s even worse, the controller is not detected at all. I put the original .cfg and everything is like before.

    Please help me, I would LOVE to get it to work!

    Thanks anyway for your time.

    PS: Works fine with my keyboard. It’s really weird that it works in the menu but not in emulators (same for PSX).

    #101322
    Profile photo of thedigi321
    thedigi321
    Participant

    im in the same boat you are in, if you find a solution please let me know my face buttons work and shoulder buttons work but not the d pad or sticks mine is the twin USB thing but the adapter is a generic chinese adapter that uses the Twin stick config but it think there are to ports (#0, and #1) and just before the game starts it will switch between port 0 and 1 idk how to stop it. that might be where are problem is

    #101346
    Profile photo of svampebob1
    svampebob1
    Participant

    I have been looking in to this problem myself today.
    When you run the Wizard for configuring the controller, it saves the configuration to /opt/retropie/emulators/retroarch/configs/USBGamepad.cfg, but Retroarc actually is using /opt/retropie/emulators/retroarch/configs/USB_Gamepad.cfg.

    Check the file USBGamepad.cfg and edit the file USB_Gamepad.cfg with the proper settings.

    #101348
    Profile photo of Floob
    Floob
    Member

    @davidgourde

    Can you post the following files for me (using attachment or pastebin)

    /home/pi/.emulationstation/es_temporaryinput.cfg
    /home/pi/.emulationstation/es_input.cfg
    /opt/retropie/configs/all/retroarch-joypads/(the only file in here?)

    Make sure your retroarch.cfg files are untouched as they were when you built the image.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101349
    Profile photo of thedigi321
    thedigi321
    Participant

    @davidgourde

    Can you post the following files for me (using attachment or pastebin)

    /home/pi/.emulationstation/es_temporaryinput.cfg
    /home/pi/.emulationstation/es_input.cfg
    /opt/retropie/configs/all/retroarch-joypads/(the only file in here?)

    Make sure your retroarch.cfg files are untouched as they were when you built the image.

    would you like mine too or just david’s?

    #101351
    Profile photo of Floob
    Floob
    Member

    Can you let me know which version of RetroPie you are running or how you built it?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101352
    Profile photo of thedigi321
    thedigi321
    Participant

    Can you let me know which version of RetroPie you are running or how you built it?

    i am using the Retropie 3.0 beta 4 and i used win32diskimager with the pre built image in the download. the only thing i have done is change the path of my roms to my usb and configured the controller with emulationstation gui and RetroArch settings neither seemed to work. the controller worked fine on 3.0 beta 2. my controller thinks that when the analog sticks are not activate that the pushing down on the right analog stick is like pressing the “A” button

    #101358
    Profile photo of Floob
    Floob
    Member

    Can you send the 3 files I listed above? I’ll see if its something straight forward.

    This output will also help me
    “ls /opt/retropie/configs/all/retroarch-joypads/”

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101359
    Profile photo of svampebob1
    svampebob1
    Participant

    Seems like my solution to this was temporary.
    After a reboot the buttons gets mixed up again… So I have the same problem here.

    I originally installed the 2.6 SD image. I ran the latest binary update today.

    While trying to fix this I deleted all the gamepad config-files in /opt/retropie/configs/all/retroarch-joypads/ and runned the retropie_setup.sh, which generated /opt/retropie/configs/all/retroarch-joypads/USBGamepad.cfg.

    I have found out that Retroarch loads /opt/retropie/emulators/retroarch/configs/USBGamepad.cfg instead.

    Still the buttons is mixed up. To fix this, I have to enter the menu in Retroarch and correct the buttons (setting x to x, y to y etc. in a Megadrive game). Saving generates a new cfg-file. Loading this file later doesn’t work, since I am unable to get out of the menu.

    Any tips would be appreciated :-).

    #101381
    Profile photo of thedigi321
    thedigi321
    Participant

    Can you send the 3 files I listed above? I’ll see if its something straight forward.

    This output will also help me
    “ls /opt/retropie/configs/all/retroarch-joypads/”

    the output is as follows:

    pi@retropie ~ $ ls /opt/retropie/configs/all/retroarch-joypads/
    Twin_USB_Joystick.cfg

    my retroarch configuration file:
    http://pastebin.com/bMtS65pF

    es_temporaryinput.cfg:
    http://pastebin.com/cTk7FuHp

    es_input.cfg:
    http://pastebin.com/rQEntgDD

    #101399
    Profile photo of Floob
    Floob
    Member

    Can you try this code:
    http://pastebin.com/raw.php?i=wcS7ekCw

    to replace what you have in your
    /opt/retropie/configs/all/retroarch-joypads/Twin_USB_Joystick.cfg

    Its not ideal, but should check a couple of things.
    Also a link to your controller will help.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101423
    Profile photo of thedigi321
    thedigi321
    Participant

    my controller is a ps2 controller with a cheap(3-4 dollars) adapter here is the closest picture i can find http://preview.tinyurl.com/qf3cvbv it is a link to the ebay that looks similar i bought the adapter almost a year ago so i wouldn’t be able to find the EXACT one but it is using the name of http://preview.tinyurl.com/ps2-controller-gamepad i only remember it because i bought that type before

    ok so the code is working the X button is mapped to the O button the analog left stick is the main movement(like the d pad) and the d pad is as far as i can tell not in use

    #101429
    Profile photo of Floob
    Floob
    Member

    Can you backup the file
    /opt/retropie/configs/all/retroarch-joypads/Twin_USB_Joystick.cfg

    then delete it and make sure that directory is empty.
    Then run the retropie-setup script and choose the register a retroarch controller option?

    That will write a file back to the directory above – can you try that one out (and post the file)?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101432
    Profile photo of davidgourde
    davidgourde
    Participant

    Oh my god THANKS!!

    I did exactly that. I had 78 files in the retroarch-joypads foler, I made a backup, deleted them and configured a new controller. Everything works perfecty fine now, thank you a lot, I really wasted a lot of time trying different things that did not work at all.

    Now EVERYTHING IS PERFECT! I can’t thank you enough! Wow!

    ^_^

    #101450
    Profile photo of thedigi321
    thedigi321
    Participant

    also worked for me thank you

    #101471
    Profile photo of Floob
    Floob
    Member

    @thedigi321
    Please could you post the new controller file that was generated and worked?
    Should be in here:
    /opt/retropie/configs/all/retroarch-joypads/

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #105141
    Profile photo of pi-guy
    pi-guy
    Participant

    @floob
    Different guy, same problem, solution didn’t work for me.
    I installed retropie 2.3 using berryboot. Proceeded to update it via the retropie_setup script (so I think I’m at retropie 3.0 but unsure how to determine that). PS3 wireless controller works fine in menu but once I start an emulator…well…no joy(stick).

    I deleted everything in the directory you list above, re-ran the joystick config and all it did was recreate the file.

    Doing some research I have a feeling that either my Retroarch didn’t get updated or somehow it’s using the wrong retroarch install…but that’s just a feeling…something to do with capitalization in RetroArch.
    Any help would be greatly appreciate.

    #105143
    Profile photo of Floob
    Floob
    Member

    Short answer is, going from 2.3 to 3.0 isnt practical.
    Just use a new image, it will resolve a lot of issues.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #105151
    Profile photo of pi-guy
    pi-guy
    Participant

    Unfortunately that’s not possible as BerryBoot only (currently) allows the download for RetroPie 2.3.

    #105154
    Profile photo of petrockblog
    petrockblog
    Keymaster

    people have already made 3.0 images http://blog.petrockblock.com/forums/topic/updating-retropie-3-0-in-berryboot/

    you can’t update from 2.3 to 3.0 without some manual work – if you delete /opt/retropie and do an install from binary that should work though and give you a fresh 3.0 set up – you will still need to clean up some old rom folder names in ~/RetroPie

    If you want to keep any of configs, it requires manual merging / cleaning up etc – so upgrade is possible, but not recommended unless you know what needs doing.

    #105161
    Profile photo of pi-guy
    pi-guy
    Participant

    Thanks buzz, I’ll give that a go.

    #105232
    Profile photo of pi-guy
    pi-guy
    Participant

    Well deleting the /opt/retropie and running the binary updates didn’t seem to work.
    I downloaded the image buzz provided and worked like a charm except I ran into theme problems again…some backgrounds didn’t display (maybe due to my roms folder being on windows share) but the start menu didn’t display properly either.
    Switched to the theme simplified_static_[canela] out of the zip file simplified_static_canela_my_red_logo_v2.0 and setup bluetooth and ps3 wireless and it all works wonderfully after I deleted the simple theme from /etc/emulationstation/simple. Hope this helps someone else.

    Side note…I have a ton of roms…maybe the simple theme has issues with that…but only seems to start up on rom folders like tg16, nes, sega32, etc. If I comment those out Simple theme works fine.
    Thanks again for pointing me in the right direction, the kids and I are ready to have some fun!

    #105233
    Profile photo of petrockblog
    petrockblog
    Keymaster

    You likely don’t have enough memory allocated for the gpu. There are many threads about this on the forum.

    not sure why deleting /opt/retropie didn’t work – that’s pretty much how my image build script prepares a new release from the old (it removes /etc/emulationstation too but that shouldn’t have mattered).

    #105250
    Profile photo of pi-guy
    pi-guy
    Participant

    It’s weird, the /boot directory doesn’t contain a config.txt file. I’m having a slight overscan issue that I corrected in Rasplex but RetroPie has no config.txt or configuration app for it. Thinking about just copying over a config.txt and placing it in the /boot directory off of a working non-berryboot retropie image. Would that work? But everything else is working super great!

    See attached for Doom (retropie) and Plex (rasplex) running on my 70″

    Attachments:
    #105253
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Look up where the file is located on a berryboot setup – I don’t use it myself – but Google knows.

    #105334
    Profile photo of pi-guy
    pi-guy
    Participant

    Hi Buzz,
    Unfortunately that’s not a lot of help. Berryboot (unless I’m mistaken) uses the same config.txt in the /boot directory like most OS’. The berryboot image that was provided seemed to have no /boot/config.txt. I’ve made one from a non-berryboot image and placed it in the boot directory – applying the settings for no-overscan. That didn’t help on either the main menu or the emulator. It appears that the 3.0 Retropie somehow doesn’t look at the config.txt upon boot up.
    As always, any assistance is appreciated – but I don’t think a “google it” will work in this case.

    #105336
    Profile photo of petrockblog
    petrockblog
    Keymaster

    http://raspberrypi.stackexchange.com/questions/6972/location-of-berryboots-config-txt

    (This came up first on google – as mentioned in it you probably need to mount the first partition somewhere).

    retropie itself doesn’t use the config.txt – it’s used by the pi firmware.

    #105365
    Profile photo of Floob
    Floob
    Member

    @pi-guy
    I had a quick Google, and this chap seems to suggest using the menu editor provided
    https://github.com/maxnet/berryboot/issues/105

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #105373
    Profile photo of pi-guy
    pi-guy
    Participant

    Partially fixed…. I found that for some reason I can see/edit the config.txt from the other OS’ I’m running but not the RP3 image that I have. I changed the config from within the berryboot loader and it fixed the resolution issue for berryboot and for RP3 boot-up but not the menu…yet…still digging.

    #106176
    Profile photo of pi-guy
    pi-guy
    Participant

    All fixed…Found my aspect ration was off on the TV itself…nothing to do with my Pie…and found a fix for my volume constantly going up and down within the game…my TV has a volume leveling feature that I turned off…and bam…all working.
    Thanks!

Viewing 30 posts - 1 through 30 (of 30 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar