Controller not working. Help?

This topic contains 5 replies, has 3 voices, and was last updated by  yogi 4 years, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1980

    WOLF13
    Participant

    Hi there,

    Great job on the script. You guys did an amazing job.

    I have installed it fine- and have gone through the initial setup of the game-pad on the first boot.

    Though- when I start an emulator (NES in this case)- my gamepad is completely unresponsive.

    What am I doing wrong? Have I missed a step?

    Any help appreciated.

    Regards

    #1983

    karloss
    Participant

    Hey mate,

    drop into terminal (F4) or ssh and do this..

    cd ~/RetroPie/emulators/RetroArch/tools

    sudo ./retroarch-joyconfig -o p1.cfg -p 1 -j 0
    ( -o for output file, -p for player, -j for joystick id )

    then do this

    sudo cat p*.cfg >> ~/RetroPie/configs/all/retroarch.cfg

    this will setup the controls for the emulators.

    good luck

    #1990

    WOLF13
    Participant

    Hi Karloss,

    Thank you for taking the time.

    I tried this last night- and had to adjust some of the code here “sudo cat p*.cfg >> ~/RetroPie/configs/all/retroarch.cfg” to get a result (or to it to look like it was doing something)

    Unfortunately, even when it ran through the commands, nothing happened when I started the NES emulator and NES rom again. It was unresponsive.

    Though, a couple of quick questions, and apologies, Im quite a novice with this.

    Also, one thing that I’ve had some confusion with when reading up about various commands- is the ~ symbol?

    Do I type the ~ symbol?
    Where I have previously, its come back with bad directory commands.

    Thank you for your help.

    Regards

    #1991

    karloss
    Participant

    Hey mate, no problem on the questions, we are all learning…

    yeah you need to put the “~” symbol, notice though, the font on this forum makes it look strange, on the sudo cat command it is the “~” that is a squigly line on the “#” key (on my uk keyboard) same for the cd command at the top, for the options for the script, it is the “-” (button next to the + key)

    I have uploaded it all in just a text file, so copy and past straight into your ssh terminal..

    you will probably need to remove all the “input_playerx_joy” stuff from the bottom of your retroarch.cfg first, so it doesn’t get confussed

    Attachments:
    1. RetroControl.txt
    #1995

    WOLF13
    Participant

    Karloss, thank you so much. This seems to have worked.

    I tried logging in via SSH to do the command, instead of doing it from the RP. Seems to have made a difference.

    The gamepad is a little laggy, though, I suspect its the gamepad itself. A very cheap USB one from chinatown near my work. Maybe I’ll try to get a better one and see if it improves.

    Regards

    #2803

    yogi
    Participant

    Hello,
    I have a similiar problem and found this thread. Thanks for the answer. Instead of opening another Thread for a similar problem i will just post here. However with your idea only 2 of 3 controllers work.
    I followed your advice and used the joyconfig tool for 3 controllers (usb noname controller from bigben) In emulationstation it works just fine for scrolling.
    The Controller configs i created with the joyconfig tool where stored at:
    /configs/all/retroarch.cfg

    Unluckily in SNES games i can only use 2 of 3 controllers. It seems retropi wont like a 3-controller setup
    Is there anything special i need to do, when i want to use three controllers?
    I only want to play SNES with 3 controllers (got secret of mana und super bomberman ROMS, which are playable with 3 controllers on original SNES)
    I Would really appreaciate some help :).

    regards
    yogi

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/