Controller issues

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of flipbug flipbug 1 year, 11 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #4185
    Profile photo of flipbug
    flipbug
    Participant

    Hi all,

    Having a terrible time trying to get controllers to work. I’ve tried two different ones with the following issues:

    Both:

      I can configure the controls for Emulationstation
      I can configure the controls for Retroarch
      When trying to configure the controls for anything else I get “Script Error”


    EDIT: I resolved the “Script Error” by reinstalling ES-Config via the Sources-based installer in retropie_config.

    Logitech F710:

      Works perfectly for menu
      Can complete controller config
      Only the GBA emulator responds to the controls I set up

    PS3 Controller (connected via USB):

      When I press a button, it inputs it twice, which screws up controller configs.
      It also only works for GBA.

    Would really appreciate some help 🙂 I am just so close here!

    If anyone else has an F710, I have some big tips for them regarding this controller (MODE and the X/D switch can really screw you over if you don’t know what they do).

    #4203
    Profile photo of RetroMarine
    RetroMarine
    Participant

    This is my retroarch.cfg for a snes usb…change the values to fit your controller and this should work fine:

    Just open:
    /home/pi/RetroPie/configs/all
    and edit retroarch.cfg to this code:
    input_player1_joypad_index = 0
    input_player1_b_btn = 2
    input_player1_a_btn = 1
    input_player1_y_btn = 3
    input_player1_x_btn = 0
    input_player1_l_btn = 4
    input_player1_r_btn = 5
    input_player1_start_btn = 9
    input_player1_select_btn = 8
    input_player1_l_y_plus = -1
    input_player1_up_axis = -1
    input_player1_l_y_minus = +1
    input_player1_down_axis = +1
    input_player1_l_x_minus = -0
    input_player1_left_axis = -0
    input_player1_l_x_plus = +0
    input_player1_right_axis = +0
    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9
    input_enable_hotkey_btn = 8
    input_save_state_btn = 4
    input_enable_hotkey_btn = 8
    input_load_state_btn = 5
    input_player2_joypad_index = 1
    input_player2_b_btn = 2
    input_player2_a_btn = 1
    input_player2_y_btn = 3
    input_player2_x_btn = 0
    input_player2_l_btn = 4
    input_player2_r_btn = 5
    input_player2_start_btn = 9
    input_player2_select_btn = 8
    input_player2_l_y_plus = -1
    input_player2_up_axis = -1
    input_player2_l_y_minus = +1
    input_player2_down_axis = +1
    input_player2_l_x_minus = -0
    input_player2_left_axis = -0
    input_player2_l_x_plus = +0
    input_player2_right_axis = +0
    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9
    input_enable_hotkey_btn = 8
    input_save_state_btn = 4
    input_enable_hotkey_btn = 8
    input_load_state_btn = 5
    (This will work on most the emulators, and I also added exit emulator by pressing select + start, as well as save state= select + L and load state= select + R)

    #4211
    Profile photo of flipbug
    flipbug
    Participant

    Hi Retromarine,

    I’ve tried similar solutions but no luck. I suspect a corrupted install, so I’m going to try a clean install of the image again.

    #4240
    Profile photo of krazedj
    krazedj
    Participant

    EDIT: I resolved the “Script Error” by reinstalling ES-Config via the Sources-based installer in retropie_config.

    How exactly do I do this? I get the same error when trying to run the configuration for 2 different emulators.

    #4242
    Profile photo of flipbug
    flipbug
    Participant

    Exit to the command line.
    cd RetroPie-Setup/
    sudo ./retropie-setup.sh

    Then select “Source-based installation”
    Then select item 61 “ES-Config” and press Enter.

    It’ll take about 30 minutes to run. Then you should be able to get past the script errors.

    #4243
    Profile photo of flipbug
    flipbug
    Participant

    Welp! After a reinstall, and then 28 hours of compiling to see if the latest versions would help… still the same issue. And then, as I was typing this, I realised that the games were working, but they were defaulting to keyboard control… so I unplugged the keyboard and boom! Controller begins working.

    Embarrassing but HEY! I am 100% working, baby 😀

    #4244
    Profile photo of flipbug
    flipbug
    Participant

    RetroMarine: Thanks for the controller config. I had to tweak it a little as my buttons are a little different, but really great having the exit command and save state functions ^^ Cheers!

    #21365
    Profile photo of muco
    Muco

    Hi Flipbug,

    Can you please post your config for Logitech Wireless F710 ? I’m also quite interested in your tips and tricks for that model. I’m struggling last 2 days for getting it worked. Got stuck for escape key, have to tie a keyboard for exiting game. Would be happy to use back button as exit.
    Also just wonder if vibration works for any of game or not.
    Cheers

    #101389
    Profile photo of flipbug
    flipbug
    Participant

    Hi Muco,

    This is what I use 🙂 The code below excludes the typical config stuff at the top.

    With the F710, make sure the switch at the front is on ‘D’. Also, watch out for the ‘mode’ button as this switches input from Dpad to left joystick.

    Lastly, you may want a separate config for PSX as the buttons are different.

    
    input_player1_joypad_index = "0"
    input_player1_b_btn = "1"
    input_player1_y_btn = "3"
    input_player1_select_btn = "6"
    input_player1_start_btn = "7"
    input_player1_up_axis = "-1"
    input_player1_down_axis = "+1"
    input_player1_left_axis = "-0"
    input_player1_right_axis = "+0"
    input_player1_a_btn = "0"
    input_player1_x_btn = "2"
    input_player1_l_btn = "4"
    input_player1_r_btn = "5"
    input_player1_l2_axis = "+2"
    input_player1_r2_axis = "+5"
    input_player1_l3_btn = "9"
    input_player1_r3_btn = "10"
    input_player1_l_x_plus_btn = "h0right"
    input_player1_l_x_minus_btn = "h0left"
    input_player1_l_y_plus_btn = "h0down"
    input_player1_l_y_minus_btn = "h0up"
    input_player1_r_x_plus_axis = "+3"
    input_player1_r_x_minus_axis = "-3"
    input_player1_r_y_plus_axis = "+4"
    input_player1_r_y_minus_axis = "-4"
    input_enable_hotkey_btn = "6"
    input_exit_emulator_btn = "7"
    input_enable_hotkey_btn = "6"
    input_save_state_btn = "4"
    input_enable_hotkey_btn = "6"
    input_load_state_btn = "5"
    input_enable_hotkey_btn = "6"
    input_state_slot_increase_btn = "+2"
    input_enable_hotkey_btn = "6"
    input_state_slot_decrease_btn = "+5"
    input_enable_hotkey_btn = "6"
    input_menu_toggle_btn = "3"
    
    input_player2_joypad_index = "1"
    input_player2_b_btn = "1"
    input_player2_y_btn = "3"
    input_player2_select_btn = "6"
    input_player2_start_btn = "7"
    input_player2_up_axis = "-1"
    input_player2_down_axis = "+1"
    input_player2_left_axis = "-0"
    input_player2_right_axis = "+0"
    input_player2_a_btn = "0"
    input_player2_x_btn = "2"
    input_player2_l_btn = "4"
    input_player2_r_btn = "5"
    input_player2_l2_axis = "+2"
    input_player2_r2_axis = "+5"
    input_player2_l3_btn = "9"
    input_player2_r3_btn = "10"
    input_player2_l_x_plus_btn = "h0right"
    input_player2_l_x_minus_btn = "h0left"
    input_player2_l_y_plus_btn = "h0down"
    input_player2_l_y_minus_btn = "h0up"
    input_player2_r_x_plus_axis = "+3"
    input_player2_r_x_minus_axis = "-3"
    input_player2_r_y_plus_axis = "+4"
    input_player2_r_y_minus_axis = "-4"
    input_enable_hotkey_btn = "6"
    input_exit_emulator_btn = "7"
    input_enable_hotkey_btn = "6"
    input_save_state_btn = "4"
    input_enable_hotkey_btn = "6"
    input_load_state_btn = "5"
    input_enable_hotkey_btn = "6"
    input_state_slot_increase_btn = "+2"
    input_enable_hotkey_btn = "6"
    input_state_slot_decrease_btn = "+5"
    input_enable_hotkey_btn = "6"
    input_menu_toggle_btn = "3"
Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar