Controller Configging in 2.0

This topic contains 10 replies, has 6 voices, and was last updated by  Mutex 3 years, 6 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #10452


    Just insalled 2.0, which i think is fantastic! However, im having a little trouble with the guts of it.

    Basically, i can’t seem to find the config files for the controllers at all. The frontend controls configged perfectly normally which is fine, and ive managed to get controllers working in games by using the setup tool in There are two things i wish to do

    1) i’d like to get into the config file itself so i can add some basic functionality that you could in 1.9.1 and below, such as the hotkey button that can be assigned to the in-game retroarch config menu andmore importantly, exiting the emulator via the pad.

    2) i can’t seem to work out where FBA is getting its controls from. FBA automatically detected and set up both my controllers AND seems to have the exit via pad functionality (via holding start + select/coin). However, the buttons themselves are slightly askew and i would like to reconfigure them to fit my pad better (im using dualshock playstation 1 pads via a USB adapter). Id love to be able to get into FBA config file as well to mess about with some shader and resolution settings as im going to be building a CPS1+2+neogeo arcade cabe using a pi and id like to alter it so it looks more realistic to the original arcade versions.

    anyone know how to do this?



    update: just found the configs in /opt/ now, same dir structure as before. That should help everyone out.

    still having the same issue with FBA though.



    The fba controls are configured in /opt/retropie/emulators/pifba/

    There’s somewhere a fba2x.cfg or something.




    I am fairly new so I usually used the controller config tool to map my buttons within the emulator, I used to find the tool in:

    cd RetroPie/emulators/RetroArch/installdir/bin
    ./retroarch-joyconfig >> ~/RetroPie/configs/all/retroarch.cfg

    Now in retroberry 2.0 its seems to be different, can someone tell how to find the tool?

    Thank you!



    The folderstructure of retropie is still the same. The only difference is that everything got moved to the /opt/ folder. You can find the retroarch-joyconfig in:



    Thank you for the response, I used the “Register RetroArch Controller” from RetroPie setup, worked perfect 🙂



    I still have some problems with this. I did find the retroarch.cfg in the /opt/retropie/configs/all folder, but it seems to only be set up for keyboard, even though i got my controller working in most emulators (not Mame4all yet). I’m also looking to enabling the hotkey exit function.



    sorry for my english . I configured everything from winscp was very easy with retropie 1.9. but now retropie 2.x not let me configure the files, it tells me access denied. is there any solution? thanks



    Hulk, you need to do the following:

    sudo -s
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    ./retroarch-joyconfig >> /opt/retropie/configs/all/retroarch.cfg



    i have the same issue as octubrq. i liked using either cyberduck or the lxde interface to easily cut and paste edits into the config files etc. but now with the new file system, i do not have the permissions to do this. how can i change permissions so that i can edit any file from anywhere and not just the command prompt?



    The new folder structure in retropie needs root privileges. So you either get a basic understanding of unix and move the files manually from /home/pi to /opt/ or you have to access the system with the root user. So log into your raspberry pi and do what InsecureSpike suggests in this thread.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss