controller cfg saves as 2Axes11KeysGamePad.cfg can't add escape combo

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project controller cfg saves as 2Axes11KeysGamePad.cfg can't add escape combo

Tagged: 

This topic contains 6 replies, has 3 voices, and was last updated by  proxycell 2 years, 10 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #84398

    benseaver
    Participant

    Unlike most controller saves I’ve seen online, my SNES style controller saves under:

    RetroPie-Setup/supplementary/RetroArchConfigs/2Axes11KeysGamePad.cfg

    I’ve added the following to try to escape:

    input_device = “2Axes 11Keys Game Pad”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”

    This does not work at all. All the other buttons work. So I’m not sure why I am getting the weird filename and why it won’t work. Any help would be much appreciated. Thanks!

    #84430

    Floob
    Member

    Try copying that into your retroarch.cfg file

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84433

    proxycell
    Participant

    we have the same controller! the Tomee SNES-style USB controllers right?
    add those last two lines to the bottom of your retroarch.ch like floob just mentioned.

    Here is my hotkey setup for that controller, i enabled rewinding in the retroarch.cfg file and set the slowmotion to 10.0

    enjoy 🙂

    input_enable_hotkey_btn = 8
    input_exit_emulator_btn = 9
    input_load_state_btn = 4
    input_save_state_btn = 5
    input_state_slot_increase_axis = -1
    input_state_slot_decrease_axis = +1
    input_menu_toggle_btn = 1
    input_rewind_btn = 3
    input_screenshot_btn = 0
    input_slowmotion_btn = 2

    #84457

    benseaver
    Participant

    Thanks. I think I’m on the right track. The hot button doesn’t seem to work but when I press start, it exits. I’m not sure why thr hot button doesn’t work because I’d rather press select+start to exit and not exit every time I only press start. I do think my controlleris a bit out of whack Since when I choose a system, the games start scrolling by and randomly exit out of the menu. Also, some issues with other games and buttons not working all the time.

    #84458

    proxycell
    Participant

    well, just move them to retroarch.cfg and it should work properly
    fyi – i changed the input_screenshot_btn to input_pause_toggle_btn – i figure having the ability to pause any game is more important since I can take screenshots from the menu

    #84460

    benseaver
    Participant

    well, just move them to retroarch.cfg and it should work properly
    fyi – i changed the input_screenshot_btn to input_pause_toggle_btn – i figure having the ability to pause any game is more important since I can take screenshots from the menu

    Yes that is the one I have! Mine seems a bit buggy though as some buttons seem to stick.

    #84495

    proxycell
    Participant

    yeah it has sticky buttons, to resolve that: before you play a game just mash every button really hard and they will “reset” for that session. they are cheap and lightweight but they do work

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/