ControlBlock doesn't trigger shutdown/LED won't indicate status

Welcome Page Forums RetroPie Project GPIO Adapter, ControlBlock etc. ControlBlock doesn't trigger shutdown/LED won't indicate status


This topic contains 7 replies, has 3 voices, and was last updated by  blue 1 year, 11 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #112255


    Hello RetroPie community.

    First of some info:
    Pi Model: 2B
    RetroPie Version Used: v3.1
    Built From: SD Image
    USB Devices connected: Pi is connected to USB Hub
    Controller used: PS3 wired
    Error Messages: –
    Guide used: The ControlBlock setup guide here

    Description of the problem:
    I have bought the self assembly version of the ControlBlock and assembled it (only added the pieces i need for connecting two SNES controllers).
    After connecting the ControlBlock with the Pie via a GPIO Cable, the switch, the LED and a power source i installed the driver as described in the guide. But now i can only switch the pie on for once. I can’t switch it of or back on again if i issue the shutdown via Emulation station or the command line. Also the LED doesn’t show anything at any time.
    I have rebooted the Pie multiple times and installed and reinstalled the driver twice, all the time without any errors i could see.
    After checking the cabeling and the soldering i couldn’t find any problems either.

    My Question: Have i missed something in the installation process? Or do i have to assemble the ControlBlock completely so it will work?
    If anyone has ideas what could be my problem or what i could test out i would be happy to hear them 🙂
    (I will attach 2 Pictures where is how the wiring from the ControlBlock to the Pie)



    well, i have the exact same problem, but i did assemble everything so that’s not our problem.

    i honestly think it’s a driver problem. let’s wait and see what the others think



    Hey Thanks for your reply!
    At least i’m not the only one expiriencing this.
    In the meantime i have reinstalled RetroPie (now version 3.3) and the driver, but without any changes to the problem.

    The weird thing is, that i can switch the pie on the first time, so there should be atleast some communication going on or am i mistaken?
    I also checked and the driver seems tho have generated the config file, but when i try to uninstall it via the commands mentioned on the GitHub page here it tells me that it can’t uninstall because “ther is no such file or directory”.

    All in all you’re right, lets wait for more ideas.



    update: i got my led to work, i had a faulty led. replaced it and that part worked. now for the not shutting down part –>

    Now my led works i can see that the control-board never goes out of the (boot) slowly fade in and out part.

    it never goes into the next state so there is no possibility to shut down. i’ll delve further into this and post my findings



    Did you enable the power switch feature in /etc/controlblockconfig.cfg ?



    I can confirm slipperypickle’s issue, in my case the connection between the LED and the board was not done properly.

    Haju, i think i have enabled it. My controlblockconfig.cfg looks as like that:
    link to pastebin
    Is that correct?




    anyone got a solution?

    haven’t been able to delve deeper into this problem, wondering if anyone did find a solution?



    I have finally solved my issue.
    There was a problem with one of the GPIO caples i used. I switched it out for another one, now it works as intended.
    Slipperypickle, you should check your connections as well 😉

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss