Connecting original NES controller ports to GPIO adapter

Home Forums RetroPie Project GPIO Adapter, ControlBlock etc. Connecting original NES controller ports to GPIO adapter

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of yesjohn yesjohn 1 year, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #105038
    Profile photo of yesjohn
    yesjohn
    Participant

    Hello everyone,

    I am working on a project to install a Raspberry Pi 2 in an original NES case but I can’t get the controller ports to work. I tried to re-solder the adapter but still no luck.

    The button on the adapter reboots the system.

    There are a few things that might be worth mentioning.

    – I’m using the original NES controller ports
    – It is/was an European NES
    – I’m not using the cable that came with the adapter, I’m using jumpwires
    – I tried original and fake NES controllers

    Thanks in advance

    #105576
    Profile photo of yesjohn
    yesjohn
    Participant

    I checked the soldering again and I had some success but still not the way it should be. JTEST gives no results and after a while Emulation starts mapping a controller but I’m not pressing any buttons on the controller.

    I’m using a Rpi2 by the way.

    #108315
    Profile photo of alley-cat-jack
    alley-cat-jack
    Participant

    If your pi was resetting, you were connecting the wrong pins on the pi together and the pi shut down because those pins should not connect.

    Can you tell us what pins you have connected to the controller ports, and what driver you are using.

    #108460
    Profile photo of yesjohn
    yesjohn
    Participant

    Thanks for your reply. I’m using a Raspberry Pi 2 and the GPIO adapter as mentioned before. I’m using the correct pins according to http://blog.petrockblock.com/2012/10/21/the-retropie-gpio-adapter/ . I’m using SNESdev as driver.

    The Raspberry Pi is rebooting after I pressed the button 5(?) times. Something it’s supposed to do according to my knowledge.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar