Changing the exit button

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of jenksie jenksie 1 year, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #111116
    Profile photo of jenksie
    jenksie
    Participant

    Hi all. I’ve bought a second pi2 to make a portable console as my main one is in my arcade machine. To save time and effort I’m using a copy of the arcade sd in the new one.

    My issue is that button 8 on my arcade stick is exit but that’s l2 on my dual shock. This makes it easy to accidentally press and rules out pax games. I’ve gone into the .cfg and deleted the line for exit unfortunately this hasn’t worked. I’ve looked in both the retroarch and pad specific .cfg and I can’t see what I’m missing.

    Is there anything else I need to look for or failing that is there a way of resetting my .cfg files?

    I’m assuming the setting is somewhere in a global file as I assume l2 isn’t exit by default.

    Thanks all.

    EDIT: I’m on mobile at the moment. When I get home later I’ll try to get my cfg files uploaded.

    #111153
    Profile photo of jenksie
    jenksie
    Participant

    Hi guys.

    I’ve added the zip containing my config. I’d really appreciate any suggestions on how to fix this.

    EDIT: I’ve discovered that the issue is each emulator CFG has button 8 as the exit. I’ve shifted that off now to the PS button which works great.

    My issue now is that my buttons are all over the place. Is there a simple way to rebind the buttons without manually altering each emulator? Sorry to be such a noob.

    Attachments:
    1. config-details.zip
    #111221
    Profile photo of jenksie
    jenksie
    Participant

    Sorry to bump so soon but I’m really struggling to sort my problem. Selecting configure controller only affects my controls in the front end. Is there anyway to reset my emulator controls to default? No matter what I try they always revert back to being wrong. Thanks.

    #111534
    Profile photo of katsudoro
    katsudoro
    Participant

    I am not an expert however let me see if I can help. You should give more information about the emulator you are using. My guess is that you are struggling with psx games right? in that case what I would do is reconfigure the buttons in the retroarch.cfg file in the psx folder. Just make sure that you write all the lines with the correct input mapping above the text that says in your text file (I am copying from your cfg file):

    #include "/opt/retropie/configs/all/retroarch.cfg"
    video_shader_enable = "false"
    input_max_users = "5"
    input_menu_toggle_gamepad_combo = "0"

    I hope I was of any help.

    #111542
    Profile photo of jenksie
    jenksie
    Participant

    Thanks I’ll have a try later. It seems to be any emulator. For example with snes games no matter how I configure the controls in retroarch or the snes cfg they default back. Ill try your suggestion. If not I may just start fresh.

    Another strange thing us that if ever I write lines above the include line to override retroarch settings, after I run the emulator they disappear.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar