Changing Box Art Dir in 3.6

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of nickpeck nickpeck 1 year, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #121357
    Profile photo of nickpeck
    nickpeck
    Participant

    Hello, I have looked everywhere and I can’t find an exact answer (oddly enough, or I’m just not typing in the question in a way that I can find posts related to it.) The scraper worked great (sselph) for all of my console systems but doesn’t come up with anything for my MAME games.

    Now, I have an images folder in my mame-advmame folder but I can’t get it to see the images (though it is pulling the game “info”).

    In the xml file it’s showing this path to the box art:

    <image>/home/pi/.emulationstation/downloaded_images/mame/1943kai-image.png</image>

    I have an image folder inside the mame-advmame folder and I was wondering if there was an easier way to point to this new location instead of trying to edit hundreds (or more) lines in the xml file itself? I’m assuming I would type the new path /home/pi/RetroPie/roms/mame-advmame/? I’m running retropie 3.6 on a Rpi3 system.

    Also, after adding a pretty big amount of mame games, I’m noticing the system is running pretty slow. Even hitting f4 takes like 2 minutes to show the command prompt, which it never did before I added the mame games. I’m guessing it’s a bit slow having a lot of zipped typed games to parse through or something?

    Thanks for any help, it’s appreciated.

    #121365
    Profile photo of petrockblog
    petrockblog
    Keymaster

    how are you launching the scraper ? the scraper module we include (which uses sselph’s scraper) saves images to the correct location.

    the delay is normal as it saves meta data on exit – there has been many posts about this already.

    #121374
    Profile photo of nickpeck
    nickpeck
    Participant

    I just tossed that last question in as I thought about it before hitting enter for the main question is all, sorry.

    I run sselph’s scraper in the command prompt (after hitting f4), but whenever I do it for the mame folder it never finds anything at all. I usually just run scraper -thumb_only for all of my systems. This always saves them in the images folder within the systems (rom) folder.

    I already have images for the mame games but it’s not seeing them so I’m guessing I’d need to have it change where it’s looking. I think my xml file is from an older install possibly which is the issue and why it’s looking in a different location. I was just wondering if I could point it to the newer location in an easy way.

    Still kinda new to all of this but I always try to look around a lot before posting because even if I don’t see a post about it I know i’m not the only one that has ever asked.

    Thanks

    #121375
    Profile photo of petrockblog
    petrockblog
    Keymaster

    if running it manually you will need to provide it the path I guess – but why bother ? Run it from retropie-setup – much simpler. https://github.com/RetroPie/RetroPie-Setup/wiki/scraper

    #121385
    Profile photo of nickpeck
    nickpeck
    Participant

    Thanks! Yah I figured out that you have to run that version from outside of EMU (when I was trying that it wouldn’t work). Thanks for the mention and the link, that helped. I’m trying to learn as much as I can as fast as I can 😀

    Thanks again and take care,

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar