Change Dgen to Picodrive in RetroPie image 1.7

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Change Dgen to Picodrive in RetroPie image 1.7

This topic contains 27 replies, has 9 voices, and was last updated by  afiedler 4 years ago.

Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
    Posts
  • #2677

    trimmtrabb
    Participant

    Took me a while to find out how to do this so thought I would save somebody some time and explain how to do it. Dgen runs ok on the Pi but not perfectly, changing the default emulator in Emulation Station to Picodrive improves performance and compatibility and adds 32x/Mega CD support. It will also use your Retroarch controls. How to install:

    Run RetroPie setup:

    cd RetroPie-Setup
    sudo ./retropie_setup.sh

    Option 4 “Update RetroPie setup script”

    restart RetroPie setup

    Option 2 “Source based installation”

    Then deselect all apart from :
    34 install Genesis core Picodrive
    57 generate config file for emulation station

    Press ok and when done reboot. Also if you want to add .bin support:

    sudo nano /home/pi/.emulationstation/es_systems.cfg

    Navigate to the Megadrive/Genesis section and add .bin & .BIN after .smd .SMD and .bin files will now be picked up.

    If you have found the solution to your problem please mark the topic as resolved.

    #2686

    petrockblog
    Keymaster

    Thanks for this guide!

    The next update of the SD-card image will use Picodrive as default core for Genesis/Megadrive.

    #2692

    trimmtrabb
    Participant

    Thankyou for all your hard work on RetroPie! The RetroPie images are great, looking forward to the next one 🙂

    If you have found the solution to your problem please mark the topic as resolved.

    #2710

    acw100
    Participant

    Trimmtrabb,

    thanks for posting this. I had already tried this once to switch to picodrive, and it didn’t work but I tried again after reading your post. same result for me. When I try to load a megadrive rom it just goes right back to emulationstation.

    Has anyone else had this issue? I’d love to get picodrive working because I’ve never been able to get DGEN to work with my controllers.

    I’ve attached my es_systems.cfg if that helps.

    Thank you!

    #2712

    acw100
    Participant

    I figured it out…. After I updated the binaries from the retropie setup script, picodrive now works and my controllers work with it. awesome!

    #2725

    mattyg8
    Participant

    how do i change the controls?

    #2727

    trimmtrabb
    Participant

    how do i change the controls?

    Picodrive uses your Retroarch controls, if you are using the latest RetroPie image there is a joypad configuration page that should set them up for you

    If you have found the solution to your problem please mark the topic as resolved.

    #2729

    mattyg8
    Participant

    I try to but no matter what when i save it i get a script error msg

    #2730

    trimmtrabb
    Participant

    I try to but no matter what when i save it i get a script error msg

    I know if you try to configure Dgen controls it throws a script error but I had no problem configuring Retroarch controls via the setup page. Alternatively you can manually edit the Retroarch controls:
    sudo nano /home/pi/RetroPie/configs/all/retroarch.cfg

    If you have found the solution to your problem please mark the topic as resolved.

    #2731

    derus
    Participant

    I did everything like you wrote but emulationstation still uses dgen. I probably have to change the master system-entry in es_system.cfg, but to what?

    #2732

    derus
    Participant

    i mean mega drive of course 😉

    #2733

    trimmtrabb
    Participant

    i mean mega drive of course ;)

    hi, you definitely regenerated a new emulation station config described in the first post? I tried the steps above on a fresh RetroPie 1.7 image and it worked fine. Can you copy and paste the contents of your es_systems.cfg here?

    If you have found the solution to your problem please mark the topic as resolved.

    #2735

    derus
    Participant

    First of all thank you for your help! I made probably something wrong and installed it again now and its working.

    But i dont really see how this one is better then Dgen. The sound seems to be worse and the 32x-games are really really slow, completely unplayable. And like in Dgen fullscreen doesnt work.

    Will the composite output work? Can i change settings somewhere do get 32x-games working? My RPi is overclocked to 800mhz by the way. I will try some Mega-CD-games tomorrow too.

    #2736

    trimmtrabb
    Participant

    I haven’t tried any 32x games, perhaps try overclocking with raspi-config. I’m not sure 32x emulation is that great from what i’ve read. When you say full screen doesn’t work are you referring to the aspect ratio, Megadrive games run at 4:3 aspect ratio so will not fill a widescreen tv unless you change the display settings on your Pi.

    If you have found the solution to your problem please mark the topic as resolved.

    #2737

    derus
    Participant

    Of course, i changed the runcommand in es_setting.cfg to 2, otherwise it will stretch the picture to 16:9. But neither Dgen or Picodrive show me a fullscreen 4:3 picture, there is still a black border arround it.

    I dont want to overlock my pi too much and i dont think that 900mhz will make such a difference, because its really slow at the moment, but maybe it try later.

    What is with composite? I cant test it at the moment. Does it work? Dgen doesnt show a picture over composite output.

    #2738

    mattyg8
    Participant

    <div class=”d4p-bbt-quote-title”>mattyg8 wrote:</div>
    I try to but no matter what when i save it i get a script error msg

    I know if you try to configure Dgen controls it throws a script error but I had no problem configuring Retroarch controls via the setup page. Alternatively you can manually edit the Retroarch controls:<br>
    sudo nano /home/pi/RetroPie/configs/all/retroarch.cfg

    all i had to do was updated ES-config in the retropie script

    #2739

    trimmtrabb
    Participant

    I have not tried composite yet. Regarding the black border I have not encountered this, the default resolution for Dgen/Picodrive is 640×480 and your tv should switch resolutions when you start the emulator unless you specify otherwise in es_systems.cfg.

    What resolution is Emulation Station displaying on your tv? You can specify resolutions by editing /boot/config.txt, more info here: http://elinux.org/RPiconfig.

    If you have found the solution to your problem please mark the topic as resolved.

    #2743

    derus
    Participant

    I know, i am always playing arround with config.txt but i cant find a solution for that. I have set up overscan for top and button to 16, because otherwise the top and button of emulationstation is cut off. Perhaps thats the problem but all the other emulators (NES, SNES, GBA) running in perfect fullscreen. I have a similar problem with gngeo (for Neo Geo) which have a even bigger black frame arround the picture.

    #2744

    derus
    Participant

    By the way the resolution in config.txt is at 720p at the moment (hdmi-group=1, hdmi-mode=4).

    #2747

    trimmtrabb
    Participant

    hmm, you have the exact same setup as me apart from the overscan, is there still a border without the overscan adjustment?

    If you have found the solution to your problem please mark the topic as resolved.

    #2749

    derus
    Participant

    I dont know why but i just experienced that the emulationstation now fits perfect without any overscan. But unfortunately it didnt change anything for picodrive. I still have the borders.

    Another curious thing: Since i removed the 32x-games form the ROM-folder, the sound problems i reported before disapeared.

    #2764

    derus
    Participant

    I updated some (other) binaries and now it works fullscreen! 😀 Really weird i dont know why…

    Another question: Picodrive also play my Master System-Roms pretty well but unfortunately also not in fullscreen. You know how to set that up? Changing runcommand to 2 doesnt seem to change anything.

    #2850

    kitchuk
    Participant

    Has anyone tried Golden Axe 2 with Picodrive? It goes to a black screen and you can hear some garbles static. Eventually it does load but takes a while. In the command line after exiting ES it mentions something about the m68k renderer. Anyone else had this problem? Not sure if I have a bad isntall or something.

    All other roms seems to be fine its jus this game. I’ll try using other roms versions.

    #2861

    kitchuk
    Participant

    I’m still having the problem with Golden Axe 2 after trying different rom versions. Can someone try this game to see if they have the same problem? I noticed that other role on using standalone binary of picodrive don’t encounter this problem.

    #2933

    dirkdiggler88
    Participant

    Hey all,

    Fairly new to this, so apologies if this is a silly question. I’m considering switching to PicoDrive, but am unsure as to how joypad mapping would work. Retroarch.cfg is only set up to map A, B, X, and Y buttons (I think) – how would one map the C and Z buttons?

    #2973

    thelostamish
    Participant

    Hi Everyone,

    I’m currently having issues with PicoDrive not recognizing the C and Z buttons as well. I’ve tried everything I can think of to get it to work, but I can’t seem to do it. Has anyone else found a fix for this.

    Why did Sega have to use a 3/6 button layout anyways!? :-p

    #3043

    petrockblog
    Keymaster

    I’m still having the problem with Golden Axe 2 after trying different rom versions. Can someone try this game to see if they have the same problem? I noticed that other role on using standalone binary of picodrive don’t encounter this problem.

    I am also facing the same issue: I am not able to run Golden Axe 2 as well.

    #3996

    afiedler
    Participant

    reall frusterated! after updating my scripts, i still dont see the picodrive option, it still only says dgen

    also, even after adding .bin .BIN to the megadrive section, it still wont play bin files, or .smd for that matter

    help is much appreciated

    EDIT
    just did a clean install of the latest sd card image, i now have the picodrive option and followed these directions, when i select a rom it goes black and returns to emulationstation
    roms sonic 1 bin, sonic 2 smd, sonic and knuckles and sonic 3 bin
    i also tried the .bin file that came with the retropie install that i think might be a BIOS file, but im not sure

    rpi model b 512mb
    memory split 256
    900mhz

Viewing 28 posts - 1 through 28 (of 28 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss