Change default controls in atari 800 emulator

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Change default controls in atari 800 emulator

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of hazza4569 hazza4569 2 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #89990
    Profile photo of labelwhore
    labelwhore
    Participant

    I want to change the default control scheme in the atari 800 emulator. For whatever reason, I’m unable to map my xbox 360 controller to the numeric keypad keys. remapping to any other key works fine, but for some reason I can’t map my controller to the numeric keypad, the controller doesn’t respond when I’ve tried. So another good option seems to be to change the default control scheme in atari 800, but theres a problem. If I change this section in .atari800.cfg, then the controls for the emulator menu get all screwed up. I’m not sure why that is, because the keys I’m changing should correspond to only player one controls, not player one and the UI.

    SDL_JOY_0_ENABLED=1
    SDL_JOY_0_LEFT=260
    SDL_JOY_0_RIGHT=262
    SDL_JOY_0_UP=264
    SDL_JOY_0_DOWN=261
    SDL_JOY_0_TRIGGER=305

    I noticed that these are the x11 key codes for the numeric keypad. So why, when I change them are the UI control mappings getting screwed up when those are currently mapped to the arrow keys?

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #89994
    Profile photo of labelwhore
    labelwhore
    Participant

    looking at the notes for version 3.0.0, it looks like we should be able to save the settings entered through the emulator UI, but how?

    http://sourceforge.net/projects/atari800/files/atari800/3.0.0/

    …just thinking out loud here. I may be able to start atari800 with the -autosave-config flag to have it autosave my settings, then remove the flag for the next time I start it up so I don’t screw anything up. I’ll try that tonight. 😉

    http://leaf.dragonflybsd.org/cgi/web-man?command=atari800&section=1

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #90035
    Profile photo of labelwhore
    labelwhore
    Participant

    I just tried the above solution. It doesn’t work, the config file gets saved, but by saving the configuration, the emulator UI controls get jacked up.

    Has anyone successfully changed the controls for player 1 in atari800 without breaking the UI controls?

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #92184
    Profile photo of hazza4569
    hazza4569
    Participant

    I’m afraid I can’t help with your solution, but I have a question of my own which you may be able to answer:

    I just managed to get the atari800 emulator working and running .atr/.ATR files, the games open and everything but I have no idea how to control anything.

    I am currently using 2 USB wired N64 controllers, which I’ve configured through retroarch.cfg and they work great in libretro emulators (NES, SNES, GB, GBC, etc.).

    However I can use neither these or the USB keyboard I have plugged in to control these games? The most I’ve managed to get is firing a ball in “Pong 2” but I’ve tried seemingly all controls on the N64 controllers and keyboard and I can’t for the life of me get the paddles to move.
    .

    Any help or even just pointing me to another forum would be much appreciated.

    #92190
    Profile photo of herbfargus
    herbfargus
    Member

    I just updated the wiki (at least for the atari800) perhaps that will give you some ideas. I’ll also see if I can test a few of my controllers at some point and maybe update the controls section for a step by step if I’m able to get it working.

    https://github.com/retropie/RetroPie-Setup/wiki/Atari-800-and-5200

    #92207
    Profile photo of hazza4569
    hazza4569
    Participant

    Thank you for the reply, I had read that page, and I must admit I don’t totally understand how the controls bit of the .atari800.cfg file works. I did try the default keyboard controls listed though but could not get them to work.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar