Certain MAME games (Capcom) are stretched vertically / have wrong aspect ratio

Welcome Page Forums RetroPie Project Video Output on RetroPie Certain MAME games (Capcom) are stretched vertically / have wrong aspect ratio

This topic contains 4 replies, has 2 voices, and was last updated by  geauxwave 2 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #103297

    geauxwave
    Participant

    Most games appear in their correct aspect ratio, even the vertical shooters like 1942, but it seems that every Capcom game (Street Fighter II, Punisher, Cadillacs & Dinosaurs, etc) in mame4all is stretched vertically on my 16:9 display. They’re actually not stretched to 100% of the display width (about 95% of it though), so maybe this is a pixel-width issue? Anyone have any ideas on how to get these Capcom games running in their correct aspect ratios?

    FYI, they run at their proper aspect ratio if I change the mame emulator to lr-imame4all, but I’d like to get this working with mame4all, if possible.

    Thanks!

    #103360

    bazola
    Participant

    I’ve never found a solution, so i switched to libretro fba for all Capcom games, problem solved 😉

    #103363

    geauxwave
    Participant

    Thanks for the reply. I researched this for a long time last night, and it seemed that while many others had the same issue, none could resolve it. I will switch to libretro for these games, as you suggest. How’s the performance? I have a Pi 2 B, so am hoping it will run well.

    I’ve never found a solution, so i switched to libretro fba for all Capcom games, problem solved

    #103366

    bazola
    Participant

    Full speed on all CPS 1 & 2 I played.
    Full speed with street fighter 3.3, but when performing super arts it slows down for like 1 second.
    My pi2 is overclocked by the way (standard pi2 overclocking option)

    #103404

    geauxwave
    Participant

    Awesome! Thanks!

    Full speed on all CPS 1 & 2 I played.
    Full speed with street fighter 3.3, but when performing super arts it slows down for like 1 second.
    My pi2 is overclocked by the way (standard pi2 overclocking option)

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/