Can't Switch To Pisnes, Help Needed (also, an overclock question)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Can't Switch To Pisnes, Help Needed (also, an overclock question)

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of tanner tanner 2 years, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #21279
    Profile photo of tanner
    tanner
    Participant

    I’ve been trying to switch to Pisnes since setting up my Pi. The RetroArch emu works fine, but sound is broken on a few of my games, games that work fine on other emulators.

    But I’m having trouble. I followed a guide by zsprawl to edit my es_systems.cfg to comment out the default emu and uncomment Pisnes. However, when I do that, Pisnes never shows up, only the default still.

    I’ve since tried a different approach; I copied the SNES section of my es_systems.cfg twice (one with PocketSnes, the other with Pisnes) so that I could use both emulators at will for certain games. I had heard this has worked for some people.

    But not me. Still, same problem, I can never see Pisnes in Emulation Station.
    It’s almost as if Pisnes has no roms in its directory. But I have ample roms and I’ve created a separate directory for Pisnes roms (and adjusted the Pisnes rom path in es_systems.cfg accordingly) and still have nothing.

    Is anybody having as much trouble as I am with this? I really just want to be able to play the games with broken sound.

    ———————————————————

    On a separate but somewhat related note, zsprawl also mentioned that he no longer uses Pisnes and has no problems with sound on his default SNES emulator since overclocking his Pi to “Turbo” setting.

    I really don’t know much about overclocking in general. I’ve heard that overclocking can be dangerous if you don’t know what you’re getting into. I don’t want to corrupt my SD card or fry any circuits, but I would love to play my games smoother.
    I have the 512 Mb Revision B model Pi. Are there any settings that should “just work” for my Pi? Anything I should be aware of? My power source is a 5V 1200mA cell phone style wall adaptor.

    Thanks to anyone who can give any sort of answer, because I’m so lost right now.

    #21470
    Profile photo of bruized
    bruized
    Participant

    Just out of curiosity, how do you know which emulator is showing up after changing es_systems.cfg? Running the sd card image of retropi 2.2 here, and when I change emulators it just shows the Super Nintendo tab with each emulator, but when running it clearly runs with the different emulator.

    As for the overclocking, if you got the sd card image of RetroPie, it’s by default overclocked to the Medium settings, which are probably settings that should just work for everyone. As long as you don’t force_turbo=1 in the overclocking you won’t void your warranty. As far as I’m aware you don’t really need to worry about much if only overclocking to the turbo settings, other than sd card corruptions, which you can get around by creating a backup image of your sd card, or by installing to usb. I set my Pi to the turbo settings and they worked fine without any problems, but I’m also running off usb.

    #21840
    Profile photo of tanner
    tanner
    Participant

    Thanks for the reply.

    The reason I know which emulator is running is by accessing the in-game emulator menu, telling me which is running.

    However, since I’m attempting to run both Pisnes and the default SNES emu simultaneously, I don’t know what that would look like or even if I’m doing it correctly.

    As for overclocking, I attempted to run turbo, but it’s just too much for my system at the moment. I may hold off until I decide to upgrade to the B+ and just run off USB then.

    For the time being, I’d really love to just be able to play certain games on Pisnes and others on RetroArch’s default.

    #21851
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Copy es_systems.cfg from /etc/emulationstation/ to /home/pi/.emulationstation/ and edit in there. To create two SNES pages in Emulation Station copy the SNES section in es_systems and rename one using <fullname>, then edit the commands to point to the seperate emulators.

    If you have found the solution to your problem please mark the topic as resolved.

    #22264
    Profile photo of tanner
    tanner
    Participant

    Thanks for the help.

    I was able to get PiSnes and the default RetroArch emu running simultaneously.

    However, it seems that simply switching emulators doesn’t fix my issue. It must be a rom compatibility issue, which is odd because these roms seem to work everywhere on every emulator except for my Pi.

    Thanks for you guys’ help. Also, if anyone can play Super Star Wars, Super Empire Strikes Back, and Super Return of the Jedi with no sound issues, please let me know which settings you’re running it under.

    Thanks.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar