can't install descent (dxx-rebirth)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project can't install descent (dxx-rebirth)

This topic contains 19 replies, has 3 voices, and was last updated by  mayner 2 years, 6 months ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #115303

    mayner
    Participant

    hi,

    i’ve tried to install dxx-rebirth with the retropie-setup script. after all is done and i’m back in the setup menu and want to go back to emulation station there is these message:

    `Could not successfully build DXX-Rebirth (Descent & Descent 2) build from source (/home/pi/RetroPie-Setup/tmp/build/dxx-rebirth/d1x-rebirth/d1x-rebirth not found).

    in an other thread a user could fix the problem after updating retropie, but this doesnÄt work for my. i had installed retropie 3.3 and updated yesterday to the current version (first the setup script, after that retropie).

    whats wrong with dxx-rebirth?

    mayner

    #115310

    petrockblog
    Keymaster

    without the build log impossible to say (it’s in the logs/ folder)

    #115311

    petrockblog
    Keymaster

    please upload it somewhere or use pastebin.com or similar and I’ll take a look.

    #115324

    mayner
    Participant

    ok here is the log. i could not upload it on pastebin because of spam (??) in the log.

    #115326

    petrockblog
    Keymaster

    Where is the log ? It was attached but then it went – did you remove it ? (unless somehow I accidentally clicked delete). Please use an external site for the log – did you uncompress before pasting into pastebin etc ?

    #115332

    herbfargus
    Member

    Even if pastebin says its spam you can enter a captcha to allow it. But you have to extract it to a text file first with 7zip or equivalent and then copy the text over manually into pastebin.

    #115439

    mayner
    Participant

    i though i’d attached the log. didn’t work.

    here is the link: http://pastebin.com/K3pQ4Gdx

    #115461

    petrockblog
    Keymaster

    missing dependency – install libraspberrypi-dev and it should build.

    #115462

    petrockblog
    Keymaster

    retropie-setup script has been updated, so you can update and try again

    #115489

    mayner
    Participant

    libraspberrypi-dev is installed, no update available.

    i’ve updated the setup script and tried again, but still doesn’t work.

    here is the new log – if you need it: http://pastebin.com/zz7rWZVA

    #115765

    mayner
    Participant

    no idea?

    #115789

    petrockblog
    Keymaster

    I’m not sure. If you create an image of your sdcard and share it with me via google drive or something I can take a look (buzz [at] exotica.org.uk)

    #115790

    petrockblog
    Keymaster

    please make sure your system is up to date also – sudo apt-get update; sudo apt-get dist-upgrade

    are you running wheezy or jessie ?

    #115880

    mayner
    Participant

    i’ve made an upgrade, but still the same.

    can i install it without the setup script and link it to emulation station manually?

    #115917

    petrockblog
    Keymaster

    you can try – but you may have the same problem – I think something is wrong with your development headers or something related. Another route would be to start with our image and try building it on there as that should work. Or provide me with an image of your card so I can check it.

    #115960

    petrockblog
    Keymaster

    Sorry – I can actually confirm the issue – maybe I broke it with some recent changes will check and get back to you. Actually, I think it could be due to upstream changes…

    #115961

    petrockblog
    Keymaster

    It’s to do with upstream changes. I didn’t think about that before, as I had built it only a few days ago. I am debugging now, to report the problem to the developers, and then I will temporarily switch our module to build a version before it stopped working.

    #115981

    petrockblog
    Keymaster

    ok. I have debugged it and opened a bug report and updated the retropie-setup script to use an older revision. should build if you update retropie-setup firt

    #116013

    mayner
    Participant

    Ok, i’ll test it when i’m a home.

    just because its interesting: is there a guide or so how i can create a new point in the emulation station menu to open programs i’ve installed without the setup-script?

    #116101

    mayner
    Participant

    ok this works. thanks for your help.

Viewing 20 posts - 1 through 20 (of 20 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

We use Cookies and similar technology to collect and analyse information about the users of this website. We use this information to enhance the content, advertising and other services available on the site. Please click ‘Accept cookies’ to consent to the use of this technology by petrockblock. You can manage your preferences at any time by visiting our Cookies Policy page.