Can't get PS3 controller to work

Home Forums RetroPie Project Everything else related to the RetroPie Project Can't get PS3 controller to work

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of zamuel zamuel 2 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #18854
    Profile photo of zamuel
    zamuel
    Participant

    I have installed Retropie 2.2 and got a blutooth dongle and a PS3 gamepad and I’m trying to make it work without any luck.
    I have installed everything and it seems to work until I try to start SIXAD. Nothing happenes then I press the PS button and after a while it says “cannot connect to sdp session”
    The blue LED on the blutooth dongle has a solid light now instead of the flashing one it had before so maybe it did work. But in emulationstation it says “no gamepads detected” so I guess not.

    #18921
    Profile photo of flipbug
    flipbug
    Participant

    There’s a special tool you can run in retropie-setup/config for setting up the PS3 controllers and Dongle. Have you used this?

    I have done this before. To sync the controllers with the Dongle, I had to attach the controllers via USB. You’ll need a USB hub to do this as you need to have the keyboard, dongle, and controller attached all at once…

    #19194
    Profile photo of zamuel
    zamuel
    Participant

    Yes I have done that. I runned the config for PS3 and I think the Dongle works. When I follow the tutorials, everything seems ok until the last step where I in sixad should press the PS button. Nothing happenes. I do see the LED on the dongle get solid instead of flashing when it isn’t connected and if I run hciconfig it shows the same mac address on both lines which if I understand it correctly says that it is connected, but no controller in Emulationstation.
    If I start Emulationstation with the controller connected with a USB cabel it says that it found a controller, but nothing happenes when I press any buttons so it doesn’t work at all.

    #20632
    Profile photo of zamuel
    zamuel
    Participant

    No one knows why PS3 controllers doesn’t work?
    I tried to download the new 2.3 image since I had the 2.2 before but with same result. Everything works fine until I start sixad and it ask for the PS button. Nothing happens and after a while it says “unable to connect to sdp session” and after a while HID error…
    I have tried to get this to work in a week now without any success. I first bought a SNES -> USB converter, that doesn’t work and when the PS3 + blutooth dongle that doesn’t work so it get’s a bit frustrating now. Running games with only keyboard is not so fun.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar