Can't Get Neo Geo Working?

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Can't Get Neo Geo Working?

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 1 year, 7 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #110540
    Profile photo of jezxlee
    jezxlee
    Participant

    Hi,

    I’ve got a Raspberry Pi 2 with current RetroPie installed.
    I followed the instructions here to setup Neo Geo console in RetroPie.
    When I run the RetroPie and select Neo Geo in the list, it shows the games I have loaded onto the MicroSD card.
    When I try to load a Neo Geo game, I get some console output and then I get booted back the RetroPie GUI system?
    Did I do something wrong? Thanks…

    Jesse

    #110541
    Profile photo of InsecureSpike
    InsecureSpike
    Participant
    #110543
    Profile photo of Floob
    Floob
    Member

    If you have followed the Wiki its likely to do with the rom versions.
    See this link
    https://github.com/RetroPie/RetroPie-Setup/wiki/Managing-ROMs

    Whicj emulator are you using for the Neo Geo?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #110630
    Profile photo of jezxlee
    jezxlee
    Participant

    If you have followed the Wiki its likely to do with the rom versions.
    See this link
    https://github.com/RetroPie/RetroPie-Setup/wiki/Managing-ROMs

    Whicj emulator are you using for the Neo Geo?

    Hi,

    Thanks for the response.
    I am using whatever the default Neo Geo emulator is.
    I think I missed the step where you press all 4 buttons to get console emulator BIOS menu.
    I’ll take a look later today and report back.
    Thanks for releasing RetroPie – it’s amazing…

    Jesse

    #110634
    Profile photo of jezxlee
    jezxlee
    Participant

    Hi,

    So I missed some instructions below:
    _______________________________________________________
    The first thing you need to do is go into the Retroarch GUI/Menu and go to “Options” and then go to “Core Options”. Make sure the “Neo Game Mode” is set to “Unibios”.
    _______________________________________________________

    I am a little confused.
    I went into Retroarch GUI/Menu and looked for “Options” but only see “Settings”?
    At the bottom-left it says: “1.2.2 – No Core”?

    What am I doing wrong, thanks!
    Got everything but Neo Geo working…

    Jesse

    #110687
    Profile photo of jezxlee
    jezxlee
    Participant

    Hi,

    So I was playing with the Neo Geo settings.
    When I selected “gngeopi” default emulator, it works!

    My only problem now is I can’t exit a Neo Geo game in progress?
    Usually pressing both [Start] & [Select] on my PS2 gamepad brings me back to RetroPie?
    Any help would be appreciated, thanks!

    Jesse

    #110689
    Profile photo of Floob
    Floob
    Member

    gngeopi uses a different romset, so I guess you have 0.138?
    The details are here:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Managing-ROMs

    You exit the gngeo emulator via the menu button, which can be set as seen here:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Neo-Geo

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar