Can't find the correct control cfg file

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Can't find the correct control cfg file

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of unconquered unconquered 2 years, 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #96844
    Profile photo of unconquered
    unconquered
    Participant

    I’m running on Beta 3 of retropie and cannot figure out how to fix my controls. I setup Retropie with Kodi and am using a wireless 360 controller (link below on the how-to I followed). The how-to I used has you install 360 drivers with retro-pi setup for the Kodi piece. Everything works great (emulation station menu controls, Kodi, etc), but in all games the controls are completed screwed. X and B are start/select, the d-pad doesn’t work at all, one of the triggers I’m pretty sure jumps.

    I installed retropie on another SD card and had no issues changing button configs to the way I wanted in /opt/retropi/configs/all or in configs/nes /megadrive, etc. Out of the box as well. The only thing I wanted to change was flipping some buttons in NES games. Other than that, I imaged an SD card, copied some roms over and that was it.

    I’ve tried grepping for specific control lines (like “start_btn = 2”) and am not coming up with anything.

    Has anyone done a similar setup and had issues with controls in games? Is it just the driver that is installed causing the issues, and nothing to do with what I put in controller configs? Thanks!

    #96881
    Profile photo of unconquered
    unconquered
    Participant

    Ok, so making some progress. With my original image of retropie 3.0, again controls in emulation station menus and Kodi work perfect, just emulator controls for playing games are screwed up.

    Now, if I exit to terminal and run jstest /dev/input/js0 I can see my inputs pressing buttons on the 360 pad. For example it tells me that B=1, start=6, and x=2.

    If I go into the retroarch setup and configure controls (I did this from the retropie menu IN emulation station) and setup for joypad controller and watch the inputs it gives me a whole new set of settings (B=6, x=7, for example).

    So it seems no matter what settings I change in /opt/retropie/configs/all in the cfg file, nothing changes in game. Meaning that config file isn’t impacting gameplay. The bit about the retroarch controller setup is where I see the issue. If I go into an NES game I found out that when I hit B and X together, it exists game back to emulation station. Note that jtest tells me that start and select at btns 6 and 7 (and in a game B+X exits the game).

    When I do the controller congfig through retroarch setup the Xbox360WirelessReceiver.cfg file is updated. However, when I go in and edit that file to set controls to what I think they should be NOTHING in game changes. B+X still exists game.

    Any ideas on how to fix this?

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar