Can't change custom controls per emulator

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Can't change custom controls per emulator

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of fantasticdan fantasticdan 1 year, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #107343
    Profile photo of fantasticdan
    fantasticdan
    Participant

    Raspberry Pi 2, Wheezy, Current emulationstation/retropie (afaik) installed from the binary option during the initial retropie script install when following the setup guide. Using a 360 wireless controller. Most everything functions as intended; stuff launches games, Kodi is listed under ports and working, and I can quit back to the menu most of the time without having to ssh in from somewhere else and issuing a reboot.

    I’m somewhat comfortable with Linux, most of my background is in Windows with a little Unix. I picked up a Raspberry Pi 2 as a learning exercise mostly, and found about this project after purchase and am now too far down the rabbit hole to back out. Anyway…

    I did the initial 360 controller config during startup, and controller works fine with default controls under everything I’ve tested. However, the controls are backwards from default SNES, NES, etc, plus some controls are missing from some emulators so I’d like to adjust buttons around uniquely on a case by case basis.

    I also need to assign different hotkeys like save states, core options menu, etc, but when I change the retroarch.cfg file in the emulator folder it doesn’t seem to have any effect. I’m copying settings either from the 360 config file from /retroarch-joypads/, or the retroarch.cfg file under /opt/retropie/configs/all/. The only thing I’ve been able to successfully do so far is to add:

    input_enable_hotkey_btn = “10”
    input_exit_emulator_btn = “10”

    to the /all/retroarch.cfg to make the xbox button quit back to the menu. I read something about the input_enable_hotkey needing to be set to enable shortcuts, but I couldn’t figure it out based on trial and error.

    If I could pull up the options menu once the emulator has launched at the very least, I could do it from there instead of editing files by hand, but I can’t get it to open using any controller buttons or by mashing the keyboard.

    I’ve been at this for about a week now and have done a ton of research, and I find conflicting information in places, or suggestions that do not seem to work.

    Here are some example links that I’ve been referencing:

    https://github.com/RetroPie/RetroPie-Setup/wiki/RetroArch-Configuration
    https://github.com/RetroPie/RetroPie-Setup/issues/357

    Change one button for an emulator

    Based on everything I’ve seen/read, I’ve found at least 4 separate places where there could be configuration files:

    /opt/retropie/emulators/retroarch/
    /opt/retropie/configs/all/retroarch-joypads
    /opt/retropie/configs/all/
    /opt/retropie/configs/emulator/

    I’ve made changes to all of these, and all I successfully got working was the xbox home button under /all/, however, in the SNES emulator the START button quits the emulator and not the home button like in everything else, so I have no idea what’s going on there.

    I know I’m doing something wrong somewhere, but I can’t figure out what it is. Anyone have any suggestions?

    #107372
    Profile photo of Floob
    Floob
    Member

    I wouldnt make any changed to the /all/retroarch.cfg

    Just change your controller file here:
    /opt/retropie/configs/all/retroarch-joypads

    Or if its just remapping, try this:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #107417
    Profile photo of fantasticdan
    fantasticdan
    Participant

    Thank you for taking the time to post. I really appreciate it. I think I figured it out, at least enough to have everything in a workable state.

    What I did was disable the change I made for the exit button in the all cfg, and in the 360 cfg file it listed the menu option as 2, with hotkey as 8. So, I held down select, pushed X and the menu came up (which wasn’t before with the exit button change). I made all the changes in the menu to the controls, saved the config (which outputs the name of the emulator.cfg, which wouldn’t load automatically upon relaunch), then quit. Then, from WinSCP I renamed the original retroarch.cfg file in each emulator folder to something irrelevant in case I ever needed it, and renamed the newly saved cfg as retroarch.cfg and it worked. Now, whenever I load up the emulator, it has my control settings saved between sessions without any menu fiddling.

    Not sure what the repercussions are from doing this, if any, but it seems to do the job for now.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar