Can't acces Retropie (RBPi2) over network

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Can't acces Retropie (RBPi2) over network

This topic contains 5 replies, has 3 voices, and was last updated by  1nsane 2 years, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #86927


    So i have been doing the initial setup.

    Im connecting trough an Ethernet Cable.

    I have updated both the Binaries and the setupscript. So i’m moving on to the network bit.

    After acquiring the IP trhough “ifconfig”, I type SET ip into my PC’s browser, but It does not connect, I have tried an FTP client (filezilla), which does not connect either.
    If I go to my router, I can see the Raspberry Pi2 with set IP listen in “ifconfig”.

    So what I am I missing?
    Thanks in advance,



    Are you connecting via the correct port and using the correct user name and password? Can you connect via ssh with putty?

    Also, make sure samba is set up correctly and running.



    To connect to your PC you either need to have the Pi connected via Ethernet cable or have already set up the WiFi through the command line.

    To setup the WiFi via command line go into the terminal and do the following:

    sudo nano /etc/network/interfaces

    You find yourself in a text editor type screen. Enter:

    auto lo
    iface lo inet loopback
    iface eth0 inet dhcp
    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet dhcp
    wpa-ssid "Your ssid"
    wpa-psk "Your password"

    Make sure you keep the ” around the SSID and password.

    The press ctrl+x, type ‘Y’ then enter.

    Reboot and then go back into the terminal and if it worked you should have an IP address in the red start up text where you have information like core temp and version.

    There are other ways involving WPA_Supplicant but I found the above way easiest. You’ll probably have text involving WPA_Supplicant already when you go into /etc/network/interfaces but I just deleted that and entered the above.



    Currently in the Samba config file,
    Workgroup is correct

    “# wins support = no”
    i removed the # and no to yes

    Still cant connect, Filezille gives me the following error:

    Connection attempt failed with “ECONNREFUSED – Connection refused by server”.

    What is the default username/password/port

    ps, using an Ethernet Cable



    Connection attempt failed with “ECONNREFUSED – Connection refused by server”.

    If its refusing the connection then the credentials aren’t right, again make sure the username and password are correct, along with the port (should be port 21 or 22, don’t remember off the top of my head). Also, you are using the local IP and your internet connection IP.

    Can you connect via SSH? Try this first.



    Hahah succes, port 22 did the trick!

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss