Cannot SSH Into RetroPie

This topic contains 13 replies, has 8 voices, and was last updated by Profile photo of salasaaron55 salasaaron55 2 years, 2 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #88223
    Profile photo of robertybob
    robertybob
    Participant

    Hi. For some reason I can no longer SSH into my RetroPie installation (2.3) , nor the new 2.6 image I’ve installed on a separate card.

    I have tried Googling this, but tbh the results have been rubbish. Does anyone know why this would suddenly have stopped working and what I can do about it?

    I know my Wifi dongle is working as I download updates on the Pi using it, and I’m definitely entering the correct IP address into Putty / WinSCP.

    Any help would be much appreciated ๐Ÿ™‚

    #88226
    Profile photo of robertybob
    robertybob
    Participant

    Also, I have not assigned a static IP.. and the reason why Googling is pointless is that the things that worked for other people can’t work for me

    e.g.

    editing /etc/xinetd.d/ssh < doesn’t exist in RetroPie (?)

    #88237
    Profile photo of Chosen
    Chosen
    Participant

    what client are you using to connect, are you getting any error message?

    #88268
    Profile photo of assault
    assault
    Participant

    ….mmh sounds weired, I would suggest to start with some basic diagnostics.
    please log on your retropie and paste here the output of those two commands:
    sudo ifconfig
    ping google.de

    on your notebook / desktop pc please download and start Angry-IP-scanner
    http://angryip.org/download/#windows
    (a nice little tool im using to discover my intranet ๐Ÿ˜‰ )
    or just try to ping the IP of you retro pie and tell us the result

    #88371
    Profile photo of Floob
    Floob
    Member

    Have you tried connecting to hostname RETROPIE as opposed to an IP?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #88390
    Profile photo of robertybob
    robertybob
    Participant

    Hiya, thanks for the replies.

    I’ve tried using Putty and WinSCP to connect but they come back with Timeout errors.

    I don’t know how to connect using just a hostname with those two programs , could you tell me how?

    I can ping Google and my Pi is picked up using Nmap (a network scanner tool) but attempting to ping the Pi results in a timeout error message too. I’m beginning to think, as it works perfectly fine via LAN, that it’s a router issue ๐Ÿ™

    #88734
    Profile photo of assault
    assault
    Participant

    how do you connect with puty ?

    your config should look like:

    Host Name
    [pi@192.168.0.XXX (<- The pis IP-Adress shown in Nmap)]

    Port
    [22]

    Connection Type
    [ ]raw [ ]telnet [X]SSH

    when you leafe the rest on default options, that should it be…

    please could you descripe more detailed what you mean with

    … as it works perfectly fine via LAN, that itโ€™s a router issue

    #88738
    Profile photo of sselph
    sselph
    Participant

    My assumptions from reading the previous posts. If they are wrong let me know.

    • SSH works when you have a wired connection
    • SSH doesn’t work over a wireless connection
    • The wireless device can access the internet
    • You can’t ping the pi over a wireless connection

    Questions:
    Is the computer attempting to connect to the pi wired or wireless?

    Things to Check:
    You can try checking your routers settings. Some routers are able to isolate each wifi client from each other and the lan. Look for something mentioning isolation.

    Auto-scraper: https://github.com/sselph/scraper

    #88795
    Profile photo of allaboutcodeorg
    allaboutcodeorg
    Participant

    Hi All About Code Here,

    1. Press menu (you selected this during setup)

    2. Select exit from the list

    3. Type sudo raspi-config into console

    4. Select Advanced Options

    5. Scroll down and select A4 SSH

    6. Enable SSH

    7. Select Finish to return to command line

    Thanks,
    All About Code Org

    allaboutcode.wix.com/home

    @all_about_code

    Attachments:
    #88802
    Profile photo of RetroMarine
    RetroMarine
    Participant

    I’ll bet you’re having the same problem I had at one point…double check your inet address for the pi you are using…they change!

    #88857
    Profile photo of robertybob
    robertybob
    Participant

    I’ll have a go at all of your suggestions tonight and report back ๐Ÿ™‚

    #88986
    Profile photo of robertybob
    robertybob
    Participant

    Right;

    Please see image below

    image

    (I installed LXDE and can’t figure out how to stop the Pi booting to the graphical log-in screen- but I’m not worried about that at the moment lol).

    these are my PuTTy settings
    image2

    and this is the error message I receive

    image3

    The assumptions Selph made were correct, if I connect this Pi to my router via LAN, I can SSH successfully.

    I have scanned using Angry IP Scanner and it didn’t pick up my Pi ๐Ÿ™

    #88993
    Profile photo of sselph
    sselph
    Participant

    Questions?
    Is the windows machine on wired or wireless?
    Are the wired and wireless router the same device?
    What is the ip of the windows machine?
    Is the pi connected to any kind of guest wireless network?
    Do you have issues connecting to/from other devices on the wireless network?

    Traffic doesn’t seem to be passing to/from the windows machine and the pi. My thinking is they are isolated somehow, either physically or logically.
    If your access point and wired router are different devices and you have different subnets, you’ll want to switch your wireless router to bridge mode and disable its DHCP server.
    If they are the same device your router may be have some option to disable isolation or bridge the two networks

    Auto-scraper: https://github.com/sselph/scraper

    #93818
    Profile photo of salasaaron55
    salasaaron55
    Participant

    Have you tried connecting to hostname RETROPIE as opposed to an IP?

    RETROPIE as the host name worked for me then just used pi and raspberry for the username and password. thanks floob

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar