Cannot get it to work , help

This topic contains 8 replies, has 8 voices, and was last updated by Profile photo of techstep techstep 2 years, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1409
    Profile photo of yodapwnedjoo
    yodapwnedjoo
    Participant

    Ok ive been at it for two days now trying to get retropie setup and working.  raspi is my first time using linux so be easy lol

    ive tried installing via image and it works but the only game it has on it is cavestory, problem is i cant seem to be able to figure out how to add my roms.

    if i f4 to go to command and type startx i get nothing (goes to black screen than back at command prompt it says xinit: connection to x server lost    .waiting fir x server to shut down server terminated succesfully)

    and i am not connected to web to add roms from ssh.(using wifi dongle that works fine in a basic raspbian install, but dont know how to configure in cmd prompt )

    so i tried the install from the RetroPie Setup Script @git hub , i got as far as having it try to boot into emulation station but it would load up and go straight back to command prompt saying that i dont have any roms installed.

    i copied and pasted them into the roms folders for each system from  raspbian , tried as .zip and extracting them (startx worked installing this way)

    Really at a loss on what im doing wrong… about to pull my hair out ,please help!

    #1410
    Profile photo of merio
    merio
    Participant

    Hi, also a nooby but I maybe able to help…

    Have you checked the es_systems.cfg in ./emulationstation? The EXTENSION= line for an emulator should match the respective extension of its roms.

    As with not being able to startx with the sd card image, maybe try downloading it and writing it to you sdcard again as your download might have been dodgy?

    I added my roms through ssh via ethernet cable bridged connection to my pc, I used the program FileZilla to just drag them into /RetroPie/roms/”emulator”

    hope you get it sorted and playing games soon 🙂

    #1414
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Maybe I should add LXDE back again to the SD card image!? I have removed it to save some space.

    #1445
    Profile photo of skater_j10
    skater_j10
    Participant

    @yodapwnedjoo If you’d like to get the LXDE desktop functionality back, just plug in an ethernet cable to your Pi (with net access obviously) and type “sudo apt-get update” and when it’s done type “sudo apt-get install lxde” you’ll be able to startx after this is complete.

    I’m not certain where the wifi configuration settings are as they are no longer on the desktop (as the regular Raspbian install has), but hopefully this helps.

    @petrockblog, yeah I’d personally like to see LXDE back on the SD card image, it makes it handy to use RetroPie as a gaming system interface and then drop-out and use LXDE as a PC interface when needed. Thanks for providing the .img by the way, it makes it so much simpler to allow users to get up and running quickly with Retro gaming on the Pi!

    #90838
    Profile photo of techstep
    techstep
    Participant

    I was going to apt-get it myself. But, roo and some others say it will cause errors now if I do. Is this true?

    I doubt most of us are worried about space with 64GB SDs being so cheap now.

    #90839
    Profile photo of herbfargus
    herbfargus
    Member

    I’m fine without LXDE, but I suppose it wouldn’t be too inconvenient for me to just uninstall it. BTW a quick perusal of this forum has solutions for many of the most commonly encountered problems including configuring WiFi. I created a video showing how to set up your WiFi dongle through the command line:

    #90840
    Profile photo of cacophony555
    cacophony555
    Participant

    I tried installing lxde via the apt-get command above and it worked fine.

    I think it’s better to not have it be part of the retropie image by default, mainly because I’m concerned about the potential performance impact due to all the dependencies that get installed. Some of those dependencies might be services that run all the time.

    #90926
    Profile photo of Floob
    Floob
    Member

    I’d agree, I like the smaller image without it.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #90936
    Profile photo of techstep
    techstep
    Participant

    Not you TOO floob! :c

    I am fine either way. I think it makes setup a bit easier for the people with less knowledge which means less forum posts… which means more time responding to more important issues… but, either way.

    I would really like to see some performance metrics. I have a sneaky feeling that there is little to no performance hit from it being installed except for a couple hundred MBs of space.

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar