Cannot get generic PS3 controller to link to bluetooth Dongle

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Cannot get generic PS3 controller to link to bluetooth Dongle

This topic contains 2 replies, has 1 voice, and was last updated by Profile photo of jwingo jwingo 1 year, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #103091
    Profile photo of jwingo
    jwingo
    Participant

    Hi there, I am, what I would like to call, an experienced newbie at Linux. I have 3 machines all running different distributions and really like what I have learned to do so far. A few months ago, I built a retropie for my GF and she loves it to pieces. We originally had a cheap usb NES style controller. I thought it would be cool to try and upgrade to a ps3 controller to play wireless, so I got a generic one and a few bluetooth dongles. That’s where the fun went far far away. I was originally using 2.6 and when following all of the instructions I found on the wiki (https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-PS3-controller) and online videos, it would get to the point of pairing the two devices and would throw an error that sixpair was not loaded into the correct folder. I tried just about everything and thought that maybe it was preloaded into the 3.0 version of Retropie. So I bust out a new sd card, load 3.0 and go to config. This time, when doing the process in the setup screen, it actually said both were set up correctly (which is odd because the wiki says it “most likely say that it couldn’t find your PS3 controller”). So then I went to the next step and when running the sixpair file, it gives a huge list of warnings such as
    nothing could be found at this address…
    Freeing device config descriptor….
    Number of possible configurations: 1
    Number of alternate settings: 1
    along with the
    Current Bluetooth master: 00:00:20:36:00:32
    Setting master bd_addr to 00:15:83:0C:BF:EB
    and then after that
    Device closed, attempting to flush all busses…

    It has never paired with the bluetooth. I have tried multiple dongles, but only the one controller so far. I even tried just plugging in the controller through usb and could get it to work on emulation station but could not get it to work one bit on any of the games. I halfway assume that is because the retroarch isn’t set correctly, but I am trying to stay to one problem at a time.
    Has anyone encountered this and have a way to help? I am frustrated.
    Thanks

    Attachments:
    #103685
    Profile photo of jwingo
    jwingo
    Participant

    Ok, so I found a cheap sony ps3 controller on craigslist close so I thought I would see if that was the problem. I guess not. I went through the same steps and while my remote buzzes when I hit the ps button (which did not happen on the generic one) I am still stuck on the page that says it needs to recognize a controller. I plugged it in with the usb and set all the controls, much like the other one, but was never able to set it up with the bluetooth. The one thing left in this equation is my cheap bluetooth dongle, but before that, I thought I would see if anyone else has seen this.

    #103789
    Profile photo of jwingo
    jwingo
    Participant

    Ok, I have tested the dongle in other ubuntu machines and it pairs just fine with other Bluetooth items. So now I know that I have a generic and official sony controller, a bluetooth that is working, a usb cable that works perfectly when plugged in, and a retroarch configured control working for both controllers when plugged in. But I still cannot get the controllers to lock to the bluetooth during the sixpair step (although the sony controller buzzes) as no js_ appears in the input test step.
    Could my sixpair files be junk? What is the best way to uninstall and reinstall? I saw one post on here that showed a Make step, but I was very confused reading it, and I consider myself pretty good at terminal commands.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar