Can I use hotkeys to set up R2 and L2 buttons?

Home Forums RetroPie Project Everything else related to the RetroPie Project Can I use hotkeys to set up R2 and L2 buttons?

Tagged: 

This topic contains 2 replies, has 1 voice, and was last updated by  stasiiik 2 years, 12 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2108
    Profile photo of jplaj
    jplaj
    Participant

    After setting up my system, I thought I might as well try to configure some of the other emulators that I previously wasn’t interested in, so I have SNES controllers and an interest in PSX.

    I’d like to know more about the hotkey function, since I need a way to use R2 and L2 on a controller that doesn’t have those buttons. My current setup is:

    input_enable_hotkey_btn = 8 
    input_exit_emulator_btn = 9
    
    input_enable_hotkey_btn = 8
    input_save_state_btn = 4
    
    input_enable_hotkey_btn = 8
    input_load_state_btn = 5

    All three of these features work very well. I thought I’d play around with the settings to see if I can get it to work. Logically, I thought that to setup a regular gameplay input, I could remove “input_player1_a_btn = 1” from the list of regular inputs, then add:

    input_enable_hotkey_btn = 8
    input_player1_a_btn = 1

    (Working out the problem with a common button on SNES seemed quicker than actually going into PSX and trying to input the secondary shoulder buttons)

    The problem is, the controller still picks up button 1 as the A button, even wen I don’t press button 8. So it seems like it’s still picking up that last line as regular code, not linked to the previous hotkey line.

    Is it possible to do what I’m asking, and use L and R as L1 and R1, then use a hotkey to make them L2 and R2?

    As always, thank you for your help.

    #2149
    Profile photo of jplaj
    jplaj
    Participant

    I’ve been playing around with it more and I’m still stumped. After trying a few different configurations, I’ve determined that the input_player_btn commands simply aren’t being tied to the hotkey command listed before them.

    Is there any way to do this, or do hotkeys only work with specific commands?

    #9419

    stasiiik

    HoBblu CauT c 6araMu dl9 Lineage 2
    http://la2-bag.at.ua/

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar