C64 (vice) no RUN/STOP key?

This topic contains 6 replies, has 2 voices, and was last updated by Profile photo of haris1977 haris1977 1 year, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #105404
    Profile photo of haris1977
    haris1977
    Participant

    I havent found a run/stop keyboard key for vice emulator. According to this :

    http://electricgardener.net/2013/12/02/raspberry-pi-distraction/

    it must be the ESC button but it “conflicts” with the es’s keyboard layout. I have not set any keyboard layout (or i think so) , but only a gamepad.

    How can i fix that?

    #105406
    Profile photo of petrockblog
    petrockblog
    Keymaster

    What do you mean it conflicts ? Have you tried pressing escape ?

    #105409
    Profile photo of haris1977
    haris1977
    Participant

    Of course and it doesn’t work..(at least on the game i tried)

    Edit: Hm..i think i found a quick solution..

    I Just went into /opt/retropie/configs/all/retroarch.cfg and changed this line (in ####input settings)

    input_exit_emulator = escape

    from “escape” to “del”..

    (the problem in these kind of emulators is that they need BOTH keyboard and Joystick to work. Another problem is that you have to manually swipe joystick port all the time – depending on the game – and that is because there is NO SAVE per game)

    #105411
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Vice isn’t a retroarch emulator and uses its own configuration. retroarch.cfg is unrelated.

    #105413
    Profile photo of haris1977
    haris1977
    Participant

    If this is the case then my rom was bad written:(

    #105417
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Not sure what you mean – which rom ? You mean the C64 software you were running or ? From my testing escape works as RUN/STOP – you can also use the on screen keyboard from the controller.

    #105424
    Profile photo of haris1977
    haris1977
    Participant

    This is the rom i used

    http://www.2shared.com/file/5Prs19LC/CommandoArcade.html

    I used an other rom and escape button worked ok.

    Edit: The specific rom (commando) doesn’t use run/stop button..I just saw it:P

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar