BT 8bitdo NES30 Pro On 3.6

This topic contains 12 replies, has 4 voices, and was last updated by Profile photo of mustbaj mustbaj 1 year, 3 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #120153
    Profile photo of mustbaj
    mustbaj
    Participant

    I am having some trouble getting my built in bluetooth to work on the pi3 correctly. Everything is named correctly within /etc/udev/rules.d/10-local.rules

    SUBSYSTEM==”input”, ATTRS{name}==”8Bitdo NES30 Pro”, MODE=”0666″, ENV{ID_INPUT_JOYSTICK}=”1″

    Once I reboot my pi3 I can’t get it to sync with my controller. How do I reconnect it?

    I tried following THIS video and he basically covers what the wiki covers here: https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-Bluetooth-controller

    Has anyone got their pi3 to boot and connect BT with an 8bitdo NES30 Pro? Also was anyone able to not only connect but configure it successfully?

    #120174
    Profile photo of mustbaj
    mustbaj
    Participant

    I got it work. The problem is that the pi3 won’t connect on boot. How do I get the bluetooth to sync when the pi turns on?

    #120175
    Profile photo of thak
    thak
    Participant

    Hi!

    So you manage to connect your 8Bitdo controller automaticly ?
    How did you do?

    #120197
    Profile photo of thak
    thak
    Participant

    Ok find out after my fourth trial 😀

    The controller need to be turn on on émulationstation screen in otder to work… Kinda strange, but now it works !

    #120220
    Profile photo of mustbaj
    mustbaj
    Participant

    Yeah very strange.. The nice thing though is that you can turn off the controller and reconnect without restarting the pi now!

    #122076
    Profile photo of auswear
    auswear
    Participant

    I’m having the same issue with the SFC30. It pairs fine and I’ve mapped the buttons fine in Joystick mode (Start + R), but every time I restart it won’t sync back up unless I re-pair.

    I’m making sure I use Start + R to turn on but still doesn’t connect. Any advice?

    #122226
    Profile photo of Floob
    Floob
    Member

    Here is an overview to make sure it reconnects when using RetroPie 3.6
    It didnt seem to reconnect for me in ES as it did for thak above. I had to use the method below. Assuming you are all on RetroPie 3.6

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #122278
    Profile photo of thak
    thak
    Participant

    Thx floob for your update!
    I’m still with retropie 3.6 and rpi3 and my nes30pro connect automaticly if i turn it on at the end of the splashscreen (if not i’d just need to reboot the controller on émulationstation screen)

    Since i found out this i’d never had anymore problem!

    Maybe it’s cause of the rpi3 bt?

    #122287
    Profile photo of Floob
    Floob
    Member

    @thank
    Which controller do you have? I couldnt get this to automatically connect with a FC30 Pro or a SFC30. Maybe I should try different firmware.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #122289
    Profile photo of thak
    thak
    Participant

    I have a nes30pro and a nes30
    And I just made à fresh install this morning and everything work fine

    I made à set up for à friend with 2 nes30 on rpi1 (and Bluetooth dongle) and that works fine too

    Just need to turn on controller on émulationstation screen

    #122290
    Profile photo of Floob
    Floob
    Member

    Maybe I need to try one of those controllers. Which firmware are you using?

    Are you making the initial pair process by pressing F4 and doing it on the command line, or do you use the retropie menu in Emulation Station?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #122291
    Profile photo of thak
    thak
    Participant

    Throught ssh connection and retropie-setup
    I followed your step, Nothing more
    For the firmware it’s the last one I check every once in a while on 8bitdo website to be sûre i didn’t miss anything

    If you need more information about my set up, i will be glad to help 🙂

    #122350
    Profile photo of mustbaj
    mustbaj
    Participant

    Hey guys. If you’re still having trouble go ahead and check this out. I wrote a nice How-To.

    How To Setup 8bitdo NES30 & FC30 Pro Controllers On a Pi3 with 3.6 from RetroPie

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar