Bluetooth Status failed after PS3 setup

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Bluetooth Status failed after PS3 setup

This topic contains 3 replies, has 2 voices, and was last updated by  miahotrod 2 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #109614


    I have noticed that before I run the PS3 set up that if I run /etc/init.d/bluetooth status The bluetooth is up and running but after the PS3 install if I run /etc/init.d/bluetooth status it shows failed even with a reboot
    than if I uninstall the PS3 controller Bluetooth is up and running when I run /etc/init.d/bluetooth status

    Also when after the PS3 install when prompted to Unplug the USB connecction to PS3 controller I get a error message sometimes
    Traceback (most recent call last): File “/opt/retropie/supplementary/runcommand/” line 49, in <module> event = IOError: [Errno 19] No such device

    Note I have experienced this with retropie 3.2 and 3.2.1 multiple clean instals
    I also test this with a CSR 4.0 BT Dongle and A Plugable BT 4.0 dongle
    also tested with and with out powered USB hub



    Since I did not get any replays I am adding some more of my findings in hopes that some one can help.
    based on another post I set sixad to boot yes and found that Sixad appears to be why my Bluetooth dongle is failing
    I have sixad set to sixad –boot-yes
    when I boot up and check Bluetooth status is failed
    when I stop sixad sixad –stop
    and check Bluetooth status is up
    when I start sixad sixad –start the controller will not pair and it times out
    and does not return to prompt
    after reboot it shows failed for the Bluetooth



    Sixad daemon stops bluetooth daemon. It’s supposed to happen.



    so if Sixad is stopping Bluetooth how do I get the PS3 controller to Pair with the Bluetooth?
    the problem I am having is Bluetooth is fine until run the PS3 controller than once installed my Bluetooth shows failed until I uninstall the PS3 controller. I have tried this with 3.1 3.2 3.2.1 I started by following the youtube video Floob has. I am unable to duplicate his results. I also have tried with 3 different Bluetooth dongles. and fresh installs. what am I missing?

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss