Bluetooth not connecting 8bitdo SFC30 (bluetoothctl – Bluez v5)

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Bluetooth not connecting 8bitdo SFC30 (bluetoothctl – Bluez v5)

This topic contains 4 replies, has 4 voices, and was last updated by  Floob 1 year, 12 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #113779

    eightkiller
    Participant

    Hy,

    I’m trying to use a 8bitdo Controller SFC30 on Retropie 3, I read many posts on forums, and tried several things but i still don’t manage to get it to work. Here is my problem.

    I followed the Bluetoothctl Wiki for Bluez V5 (the Retropie tutorial writes about Bluez V4, with Wheezy not Jessie :s)

    Which told me to:

    power on
    scan on
    agent on
    devices (to get the mac address of my device)
    trust *Mac_address_of_my_controller*
    pair *Mac_address_of_my_controller*
    connect *Mac_address_of_my_controller*
    

    I managed to make it work once, but now when i try to connect i always get

    [bluetooth]# connect my:controller:mac:address
    Attempting to connect to my:my:controller:mac:address
    [CHG] Device my:controller:mac:address Connected: yes
    Failed to connect: org.bluez.Error.Failed
    [CHG] Device my:controller:mac:address Connected: no
    

    I don’t know why it worked once and it’s not working anymore, the pairing is already done, i get an error “AlreadyExists” when i try to pair again.

    I tried to look for error by using :

    root@retropie:~# systemctl status bluetooth
    Failed to get D-Bus connection: Unknown error -1
    root@retropie:~# systemctl --user status
    Failed to get D-Bus connection: Unknown error -1
    

    Without any success 🙁

    If you have any idea I would be grateful !

    P.S. I would also like to automatically launch the synchro by connecting automatically the blueetooh controller when i boot my Raspberry, maybe something inside rc.local ?, the Retropie tutorial is for Bluez V4, not working the same way with Bluez v5 !, I tried what was advised on the wiki to auto. launch this, but it’s not doing it :s)

    #114063

    eightkiller
    Participant

    Still no one to help me ? :s

    #114074

    teirich
    Participant

    Hey, having the same problem as you. Please see my post here and try the second part, that may help you get a little further.

    https://github.com/RetroPie/RetroPie-Setup/issues/1185#issuecomment-171677656

    #114968

    abs7
    Participant

    I think i’ve seen this error before. Try doing all the commands as root. in the terminal, type: sudo su

    Let me know how you get on/

    #114977

    Floob
    Member

    If you are trying to get your bluetooth controller working with RetroPie, please check the Wiki. The process there will auto reconnect on startup.

    https://github.com/retropie/retropie-setup/wiki/Setting-up-a-Bluetooth-controller

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss