Solve:Bluetooth Keyboard worked during the start but failed to work subsequently

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Solve:Bluetooth Keyboard worked during the start but failed to work subsequently

This topic contains 6 replies, has 2 voices, and was last updated by Profile photo of deathsyct deathsyct 1 year, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #115812
    Profile photo of deathsyct
    deathsyct
    Participant

    Hi, I have paired my bluetooth keyboard with retropie successfully for the first time and it work perfectly.
    However, upon restarting my retropie, the bluetooth keyboard failed to work.
    I even remove all bluetooth settings and re-setup again but it did not work this time.

    any idea what went wrong?

    below are the steps I did:
    – download all the required packages
    – hcitool scan to get the mac address of my keyboard
    – bluez-simple-agent to connect and pair my keyboard
    – bluez-test-device trusted to ensure it gets connected in future
    – bluez-test-input to test the input

    all the above steps went well without any errors but my keyboard is still not working in emulationstation.

    #115813
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Did you try using the bluetooth configuration tool in retropie-setup ?

    #115814
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Which version of RetroPie ? Jessie or Wheezy ?

    #115867
    Profile photo of deathsyct
    deathsyct
    Participant

    hi buzz, i’m using the image build from smithers which has dual boot of RetroPie v3.2.1 & OpenELEC v6 (KODI v15.2 Isengard)

    below is what i got when i did a hcitool con

    Connections:
            < ACL 20:73:00:50:98:58 handle 0 state 1 lm MASTER AUTH

    however when i press any key on the bluetooth keyboard, its not responding.
    any idea what could be the reason?

    #116217
    Profile photo of deathsyct
    deathsyct
    Participant

    i notice that sometimes, after restart, the keyboard manage to work.
    any idea why this is happening?

    #116240
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I cannot support 3rd party images.

    Please try from the latest official image, and use the bluetooth pairing module from retropie-setup to pair the keyboard.

    #116343
    Profile photo of deathsyct
    deathsyct
    Participant

    no worries.
    i manage to get it resolved.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar