Bezel artwork support


This topic contains 6 replies, has 4 voices, and was last updated by  Billy T. Pilgrim 2 years, 3 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #106725


    I know that this would be more of a emulation station issue. And if this feature is already in then sorry, had a look and couldn’t find anything on it.

    I want to use bezel artwork for my games to display instruction cards etc much like the attached image

    I would also like to use bezels for certain systems that look better on small screens like in the attached image



    Are meaning something like borders kinda like this?

    You could probably implement it through retroarch as an overlay/shader : I don’t know much about it though



    Looks perfect. Thanks heaps. I had a feeling i missed it and it was prob already a feature somewhere. Looks as though its only for retroarch though. Hopefully i can find a solution for other systems


    Billy T. Pilgrim

    It’s probably worth switching over to RetroArch if you want bezels, to be honest. The versions of MAME and FBA available on the Pi don’t like the new (easily available) layout files, and it’s really hard to get hold of the older ones. The RetroArch versions support a lot of stuff between them and have the benefit of shaders and the like.

    I’ve made a guide in a new thread, this should sort you out if you do want to try with RetroArch:

    [GUIDE] Overlays & Arcade Bezels in RetroArch



    Thanks heaps i really appreciate that.

    Couldnt the old ones just be remade? I dont mind doing the work.
    I would really like to get it to work on advance mame



    I’d love to add overlays “bezels” to all of the 4:3 aspect systems. But from what I’ve tested, adding an overlay affects the performance. Even on Raspberry Pi 2. So I’ve opted to avoid using overlays. 🙁


    Billy T. Pilgrim

    rookervik, what systems are you having performance issues with? There’s no reason you shouldn’t have perfect performance on Pi2 with a 1080p overlay. There’s a couple of things you might want to check:

    Is your Pi overclocked? I have mine set to the Pi2 setting.

    Are you running at an unusual resolution?

    Does your retroarch.cfg have video_threaded set to false? This was changed recently in the RetroPie-Setup script to be false by default – however, it was found it negatively affected performance if you were using shaders or overlays. If it’s false, try setting it to true and see if that helps.

    Otherwise, feel free to PM me and I’ll see what else I can do to sort you out.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss