Beginner-level tutorial for running NES controllers off GPIO

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Beginner-level tutorial for running NES controllers off GPIO

This topic contains 2 replies, has 1 voice, and was last updated by Profile photo of shaneriley shaneriley 2 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #82876
    Profile photo of shaneriley
    shaneriley
    Participant

    I’ve been trying to get my NES controller port to work from the GPIO pins off and on for the past 6 months, and have yet to be able to make them work. Every forum thread or repo README feels like it gets most of the way there, then there’s some error that prevents me from completing the setup.

    Most recently, I tried installing the gamecon_gpio_rpi_dkms and it told me dmks is not installed. I ran sudo apt-get install dkms and got a warning: “version ‘*-*’ has bad syntax: version number does not start with digit
    It is likely that 3.12.32+ belongs to a chroot’s host
    Building for architecture armv61
    Module build for the currently running kernel was skipped since the
    kernel source for this kernel does not seem to be installed.”

    I’ve tried getting it set up from the RetroPie SD card image, from installing via source, and installing from binaries. Installing SNESDev-RPi using the README instructions didn’t get it working, and the page at https://github.com/retropie/RetroPie-Setup/wiki/gamecon_gpio_rpi doesn’t tell me how to actually install and run the gamecon_gpio.

    Is there any tutorial out there that will actually walk you through how to set this up? It seems everyone else is able to get this thing working but me, and every time I leave it for a month or two thinking that, when I return to it, someone will have written a more comprehensive post on setting it up.

    #83043
    Profile photo of shaneriley
    shaneriley
    Participant

    Nobody has any information they can give me that may help? What did every one else use to figure out how to wire up and configure your controllers through GPIO?

    #83206
    Profile photo of shaneriley
    shaneriley
    Participant

    I’m in serious need of help with getting the NES controller to work using the GPIO pins. I noticed that when I shut down the Pi, it gives a kernel panic. Could it be something related to that? Does this with or without the controller port hooked up to the GPIO.

    I also can’t seem to get an installation of RetroPie with jstest, so I can’t see if the controller via GPIO is working.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar