BasiliskII and Macintosh emulator questions

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project BasiliskII and Macintosh emulator questions

This topic contains 17 replies, has 5 voices, and was last updated by  petrockblog 1 year, 12 months ago.

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
  • #85220


    First off, hello and thank you for doing this great project. I’m about six weeks into Raspberry Pi ownership and this is exactly the kind of thing that I had hoped I’d be able to do with my Pi when I bought it. It would be great if we as a community could get it to the point where it’s included on Noobs and listed on the official website.

    I have come somewhat unstuck, however, with raygan’s installation instructions for BasiliskII here:

    I get as far as fetching the src from GitHub and running ./ but once this is completed I get an error message when it comes to entering the ./configure –enable-sdl-video –enable-sdl-audio –disable-vosf –disable-jit-compiler command.

    After struggling to find any other instructions out there from anyone having the same issue, I started over and after running ./ I simply entered ./configure without the enable and disable options. Everything seemed to be working fine, and I even got as far as entering make and make install, but once that had completed and I entered both the commands to start the next part of raygan’s instructions, firstly xinit which BasiliskII (with parenthesis removed here because of this forum’s BBCode auto-formatting) and the command BasiliskII (both suggested by the author on his blog) but the Pi simply switches to a blank screen for a second, as if it is about to load X11, and then returns to the command prompt with an error message.

    I followed raygan’s instructions to the letter up until this point, but in part 2 of his install tutorial he simply says “Start X11 on your Pi. Run BasiliskII and configure its options using the GUI.” without explaining how this is done if X11 won’t start.

    I did come unstuck on one or two other points which I managed to fix myself, such as finding that Apple no-longer host System 7.5.3 install disks on their website, for example. These can now be found at:

    I also tried installing the xorg window manager manually (as it were) by grabbing it via apt-get, but still no dice.

    Could this have anything to do with choosing to ‘Remove raspian files not needed by RetrpPie’ in retropie-setup perhaps? Should I reinstall the latest version of RetroPie on the SDCard and start over?

    I also thought that it could be to do with my still having Emulation Station running on the Pi while installing BasiliskII via SSH from Terminal on my Mac. So I instead booted RetroPie to the command line, instead of automatically entering Emulation Station, and tried following raygan’s BasiliskII install instructions once again, but I still came unstuck at the point of entering the ./configure options and make, make install still didn’t appear to work properly, and I still got an error when trying to launch X11.

    My Pi is a B+ with no modifications other than a few heat-syncs so I can clock it to Medium for RetroPie and High for Kodi.

    It would be great to get some of my old Macintosh software running again, so if anyone can help it would be much appreciated.

    EDIT: I should also add that I do have all the necessary .ROM files courtesy of a certain torrent site I won’t name, and that I tried using the MacPlus.ROM, Classic.ROM and Performa580.ROM files as-per raygan’s instructions still to no avail.



    After typing make this is what happens when I type make install:

    pi@retropie ~/RetroPie/emulators/macemu/BasiliskII/src/Unix $ make install
    /bin/sh ./mkinstalldirs /usr/local/bin /usr/local/share/man/man1 /usr/local/share/BasiliskII
    /usr/bin/install -c BasiliskII /usr/local/bin/BasiliskII
    /usr/bin/install: cannot remove `
    /usr/local/bin/BasiliskII’: Permission denied
    Makefile:145: recipe for target ‘install’ failed
    make: *** [install] Error 1
    pi@retropie ~/RetroPie/emulators/macemu/BasiliskII/src/Unix $ sudo make install
    /bin/sh ./mkinstalldirs /usr/local/bin /usr/local/share/man/man1 /usr/local/share/BasiliskII
    /usr/bin/install -c BasiliskII /usr/local/bin/BasiliskII
    if test -f “”; then \
    /usr/bin/install -c /usr/local/bin/; \
    /usr/bin/install -c -m 644 ./BasiliskII.1 /usr/local/share/man/man1/BasiliskII.1
    /usr/bin/install -c -m 644 ./../SDL/keycodes /usr/local/share/BasiliskII/keycodes
    /usr/bin/install -c -m 644 ./fbdevices /usr/local/share/BasiliskII/fbdevices
    /usr/bin/install -c -m 644 ./tunconfig /usr/local/share/BasiliskII/tunconfig
    pi@retropie ~/RetroPie/emulators/macemu/BasiliskII/src/Unix $ xinit which BasiliskII

    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/retropie:0
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

    X.Org X Server 1.12.4
    Release Date: 2012-08-27
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.2.0-2-mx5 armv7l Debian
    Current Operating System: Linux retropie 3.12.35+ #730 PREEMPT Fri Dec 19 18:31:24 GMT 2014 armv6l
    Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2708.boardrev=0x10 bcm2708.serial=0xe5864953 smsc95xx.macaddr=B8:27:EB:86:49:53 bcm2708_fb.fbswap=1 bcm2708.disk_led_gpio=47 bcm2708.disk_led_active_low=0 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000 dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
    Build Date: 10 December 2014 09:32:00PM
    xorg-server 2:1.12.4-6+deb7u5 (Moritz Muehlenhoff <>)
    Current version of pixman: 0.33.1
    Before reporting problems, check
    to make sure that you have the latest version.
    Markers: (–) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: “/var/log/Xorg.0.log”, Time: Fri Jan 16 15:46:18 2015
    (==) Using system config directory “/usr/share/X11/xorg.conf.d”
    FATAL: Module g2d_23 not found.
    Basilisk II V1.0 by Christian Bauer et al.
    ERROR: Cannot open ROM file.
    xinit: connection to X server lost

    waiting for X server to shut down Server terminated successfully (0). Closing log file.

    pi@retropie ~/RetroPie/emulators/macemu/BasiliskII/src/Unix $

    And this is what happens when I try to start X11 by typing BasiliskII

    pi@retropie ~/RetroPie/emulators/macemu/BasiliskII/src/Unix $ BasiliskII
    Basilisk II V1.0 by Christian Bauer et al.
    ERROR: Could not initialize SDL: Unable to open a console terminal.


    retropie comes with a working basiliskii and it doesn’t require manual building etc. it also doesn’t require X to run. the latest version (check the image downloads for ready / setup image), looks by default for a mac.rom and a disk.img file in the ~/RetroPie/roms/mac folder – I have tested it booting a prebuilt image files from with the performa rom.

    if wanting to replicate our build elsewhere, check out the source in our repository in scriptmodules/emualators/

    you can also use retropie to build manually by doing

    sudo ./ basilisk sources
    sudo ./ basilisk build
    sudo ./ basilisk install
    sudo ./ basilisk configure


    sudo ./ basilisk

    which will do all of the above.



    Thank you for the reply. Yes, I built BasiliskII from source using the retropie-setup and placed the nessasery .img and .rom files in the correct folder, but I’m getting ‘ERROR: Cannot open ROM file’. I’ve tried some other ROMs I was able to find elsewhere and still no dice. Do they have to be given specific upper or lowercase filenames?



    please give me details of exactly the filenames and file locations (output from ls -la / pwd for example)

    the filesystem is case sensitive – they need to be lowercase.

    are you running the latest retropie image 2.4.x ?



    pi@retropie ~/RetroPie/roms/macintosh $ ls -la
    total 31772
    drwxrwxr-x 2 root pi 4096 Jan 17 15:33 .
    drwxr-xr-t 51 root pi 4096 Jul 20 17:07 ..
    -rw-r–r– 1 pi pi 4096 Jan 17 12:26 ._disk.img
    -rw-r–r– 1 pi pi 31457280 Oct 19 2013 disk.img
    -rw-r–r– 1 pi pi 4096 Jan 15 15:24 ._.DS_Store
    -rw-r–r– 1 pi pi 6148 Jan 17 11:18 .DS_Store
    -rw-r–r– 1 pi pi 1048576 Jan 15 07:51 mac.rom
    -rw-r–r– 1 pi pi 4096 Jan 17 12:36 ._PERFORMA630.ROM
    -rw-r–r– 1 root root 0 Jan 17 13:04 Start.txt
    pi@retropie ~/RetroPie/roms/macintosh $

    I have the latest version of RetroPie, yes. Thanks for taking a look at this. It’s been frustrating me for days.



    and what is the output of this command from the terminal:

    grep "BasiliskII" /etc/emulationstation/es_system.cfg


    Hey, sorry for delay in replying. Long weekend.

    I assume you meant ‘grep “BasiliskII” /etc/emulationstation/es_systems.cfg and not grep “BasiliskII” /etc/emulationstation/es_system.cfg’ (systems.cfg not system.cfg)?

    The output text is:

    <command>/opt/retropie/supplementary/runcommand/ 1 “/opt/retropie/emulators/basilisk/bin/BasiliskII –rom /home/pi/RetroPie/roms/macintosh/mac.rom –disk /home/pi/RetroPie/roms/macintosh/disk.img” “basilisk”</command>



    yep. sorry.

    well, that looks fine – so it should find the rom/disk image. you are launching from emulationstation right?



    Yup! I hit Start and it changes to a blank screen for a second, thinks about it, flickers for a while, then switches back to the console where “Error: Cannot open ROM” appears for a moment before going back to the EmulationStation browser.



    no idea then – it looks as though you have the rom in place, and the disk.img so it should work. maybe try another rom?

    I have tested it with the files from this page –


    and it works fine. Maybe double check the filenames – that there is no trailing space or something.



    THAT’S GOT IT!! works as expected!

    Renamed PERFORMA.ROM to mac.rom, chose Start from EmulationStation and boom!

    Thank you!



    I too was having considerable difficulty getting BasiliskII to run on my Raspberry Pi model B+. Using the files as described in buzz’s 01/19/2015 13:10 post I was able to get BasiliskII to run from EmulationStation. In fact, it goes right into a Mac desktop and skips the setup steps described in other places and is running system 7.5.5.

    The problem I have is that the hard drive is only 2 MB so it’s not big enough to install anything else on the emulated Mac. How can I access the configuration screens of BasiliskII to set the hard drive to something more reasonable? I assume it will have to be done outside EmulationStation but I haven’t the foggiest idea how to do it. Thanks for any help.



    Post count: 1
    Topics: 0Replies: 1
    I too was having considerable difficulty getting BasiliskII to run on my Raspberry Pi model B+. Using the files as described in buzz’s 01/19/2015 13:10 post I was able to get BasiliskII to run from EmulationStation. In fact, it goes right into a Mac desktop and skips the setup steps described in other

    I have the same question on running Basilisk on a Raspberry 2. Mine goes directly to desktop too. I’m not terribly technical so I’m not good with editing configuration files.

    I imagine if the disk.img file could be expanded in another program before mounting it on Raspberry that would be helpful. I might try to figure out that option.

    Or figuring out a way for the emulator to mount a 2nd bigger .img file on setup where you could store/install games. I have an .image file that I use with Basilisk on Windows, but renaming it disk.img doesn’t work.



    I’d like to add the same question as the last two posts.

    I can get it to load with the mac.rom and disk.img files, but there is only 2MB free on the disk image.

    Has anyone found a solution to this?



    I would do this with a copy of basiliskii on PC. Note you can access the rpi filesystem from within the emulation also.



    Is there a way to create a new disk image from the Basilisk GUI on the Pi?



    no since we dont include the basilisk gui – but easier to do on a pc anyway.

Viewing 18 posts - 1 through 18 (of 18 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss